nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia drivers lock up xwindows (http://www.nvnews.net/vbulletin/showthread.php?t=5298)

reduc 12-18-02 12:18 AM

nvidia drivers lock up xwindows
 
I have a geforce4 mx420 card and had a mandrake 9.0 install that worked fine with the generic nvidia drivers (Geforce 4 (generic)). Of course, these drivers didn't support opengl, so I downloaded and installed the 1.0-4191 kernel and glx drivers. I used NVchooser.sh to pick the correct files. I edited my XF86Config like the readme told me to. I started up x and everything seemed to work ok for a couple of min and then my system just locked. I could move the mouse, but when I tried clicking on windows/icons nothing happened. I then went back to the generic drivers and everything worked ok.

Just to test my install, I installed linux again. This time with RH 8.0. I also decided to compile the the correct drivers from the tar.gz files. I ran into the exact same problem again...the screen just freezes. No errors or anything. Anyone have any suggestions?

I doubt it's the card or hardware causing the problem because they run fine in win2k and in linux when I'm not using the drivers from nvidia.

Wolfman [TWP] 12-18-02 01:00 AM

Did you get any error when you ran the recompile??

If you did, then you will also need to install the kernel Source for RH8.0 as it doesn't do that by default.

For RH8.0 I download the *.src.rpm files and compile them.

to do that:

rpmbuild --rebuild NVIDIA_kernel-version_number.src.rpm

rpmbuild --rebuild NVIDIA_GLX-version_number.src.rpm

The install them using RPM -Uvh NVIDIA_kernel-Version_number.i386.rpm

The compile will store the *.i386.rpm files in the usr/src/redhat/RPMS/i386 directory.

Then of course edit the XF86Config file in the etc/X11 directory as described in the readme file.

Hope this helps,

Wolf :D

nightshadow 12-18-02 10:53 AM

i have the same problem on my laptop, toshiba 1900-703 equiped with Geforce4 Go 440.
I solved the problem by disabling all extra options like cursor shadow or render.

nightshadow 12-18-02 10:55 AM

ah.... i'm using Debian sid (unstable branch).....


All times are GMT -5. The time now is 03:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.