nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVchooser giving me a bum steer ? (http://www.nvnews.net/vbulletin/showthread.php?t=5318)

sj1davies 12-18-02 09:49 AM

NVchooser giving me a bum steer ?
I am a Newbie to Linux - large systems guy, forgive me.
New install,
Did some research, did plenty of YOU updating andthen got to the graphics bit....

NVchooser.sh is telling me use

Trouble is I can't find them anywhere.

Suse 8.1 professional
AMD cpu
K7S5A mobo
GeForce 4 MX 440 card

Is NVchooser mad ? ( I got it last night from the nvidia site so I expect it is current ).

After reviewing various mb traffic it seems choosing/finding the right drivers is a common problem.

Am willing to tackle tarballs and source modules if needed.

volt 12-18-02 09:55 AM

Just get version 3123 instead:



I always use the source though:



Mandarb1 12-18-02 10:29 AM

The rpms make it really easy to install with SuSE 8.1 because YaST2 does all of the work for you. DL the rpms and then open up the rpms, click the button "Install with YaST" and it does the installing for you. The order in which you install the rpms is important also. I forget if its GLX then kernel or kernel then GLX. The readme on the nVidia webpage will say for sure.

bwkaz 12-18-02 10:32 AM

Which page did you get NVchooser.sh from? Grab it from the same page as what has the driver version you want...

So do it like this:

1) Decide which driver version to get (if you go to nvidia.com, hit drivers, and fill in graphics driver, geforce, and linux ia32, you'll go to the most current version's page -- but some people have been having problems with 4191, which is probably why volt suggested 3123)

2) Go to that version driver's download page

3) Grab the NVchooser that's linked there

4) Run it

5) Download that file from the same page

sj1davies 12-18-02 12:13 PM

Thanks folks ! Brilliant responses.
Am going with the rpms for now but even a I type this my modem is squirting down the source packages as well.

Tried the advice re 'choosing the chooser' and I get a size mismatch on the download... bummer.
Have looked in the script I do have (never seen one before thats how much of a linux newbie I am..) and its obvious enough how it comes up with the name of a module that doesn't exist - weird way to code something 'specific' I gotta say.

Anyway when downloads complete will re boot into Suse and give 'em a wizz.

Then after I have et up firewall/iptables/intrusion detection/ cookie management/antivirus/junkbuster proxy/mail and auto dialing i may just try using suse for all my net needs. (yep am usng a 'Bill' system to do this update - not for too much longer I hope).

Will post results for those that follow.

Once again, many thanks.

sj1davies 12-18-02 06:11 PM

1 Attachment(s)
Tried the src rpm but got all kinds of horrible messages so went for the tar method. Followed instructions and all seemed to go well (even changed the runlevel okay) but...
3Ddiag now tells me 'bad' things.
Any Ideas ? or is it 'normal'

meanwhile I will read some of the threads in the same vein.

bwkaz 12-18-02 08:51 PM

Instead of 3Ddiag, try using nv_check.sh.

I've got a newer version here.

Although you should probably get it quite soon (i.e. tonight), because my entire site will be going down for like 3 weeks over Christmas break starting tomorrow morning. Power will be off here in the dorms, so the site can't be up while I'm gone. If you don't get it, you can probably find it somewhere else, but it might be slightly misleading if your distro uses devfs.

sj1davies 12-19-02 05:49 AM

Have glommed a copy off ...
Wil run it when I reboot into Suse.

Just one thing - devfs ????? I am a Linux Newbie and my accelerated learning (due to these drivers) hasn't got me to devfs yet.

sj1davies 12-19-02 06:59 AM

Nice script. Much better than nvchooser.

It tells me that libglx.so is missing.
also X doesn't start now but it did last night and I haven't updated a thing since then (been on Widoze).
Looks like a reinstall to me. the Nvidia doc says that the tarball method removes the previous drivers when the ;make install' is run so I will stick with that.

I have no idea if that does a clean-up as well but we'll see.

Thank Heavens for dual boot ! (and good Fora !!).

sj1davies 12-19-02 09:36 AM

Re installed tarballs - looked clean and dandy. On reboot (at appropriate runlevel) X started fine.
found out about the change to the 3dconfig file and did that and 3Ddiagthat comes up mostly okay - it doesn't find the kernel module. (I even has a vi session - very weird to me that editor)
Nv-Check also okayish but think that the kernel module isn't loaded however lsmod shows a whacking 1.4 meg module in there.

tried to enable 3d via Sax (standalone and via Yast) and it tells me I need to install NVIDIA_GLX and NVIDIA_kernel modules. I think its looking for the standard supplied modules. I did a YOU update on these before tackling the latest drivers as an article on the register had warned about this checking going on.

I don't really want to re-install Suse - its the hours of YOU updating on a v.90 modem with an ISP with a 2 hour cutoff that puts me off - but I need to find out what state my software is actually in and how to fix it.

Some pointers to procedure/protocol would be great - I can read fast...

sj1davies 12-19-02 06:22 PM

For anyone still awake...
Using tarballs of either 3123 or 4191 rivers got me in the same quandry.
When trying to enable 3d in SaX it said it wouldn't unless I install NVIDIA_GLX...something I had done before trying the tarballs.
That and various checks weren't happy with the kernel module - but the make for that was clean and lsmod showed it in there.

So... I did a YOU and downloaded the Nvidia code from there and let it install. rebooted and when i went into SaX to enable 3D it was already enabled...

So do I try a newer tarball now ? I don't know but I sure can change runlevel, apply the code and reboot back to X quite quickly now....and I know about a few commands I didn't before.

There seems a lot of traffic on these Nvidia drivers so I think I may wait until the issues go away (in 2003....).

Hope all this typing has saved someother poor devil going through the hoops.

All times are GMT -5. The time now is 10:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.