nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   newbies' question (http://www.nvnews.net/vbulletin/showthread.php?t=5332)

honghsu 12-18-02 03:31 PM

newbies' question: nForce against GeForce
 
Greeting All,

I am wondering this is right place to ask questions regarding installation of NVIDIA video driver.

I have Asus A7N266-VM/LAN/AA motherboard which has NVIDIA GeForce 2 Integrated GPU. The cpu is AMD Athlon XP 1600+ and the redhat Linux 7.3 (kernel 2.4.18-3) is installed. The XFree86 is 4.2.0. But no X windows at all.

There is a nv_drv.o at /usr/X11R6/lib/modules/drivers/
So I run
#rpm -ivh NVIDIA_kernel-1.0-4191.rh7xup_2.4.18-18.7.x.athlon.rpm


Got error message:
modprobe: Can't locate module nvidia
Failed to install nvidia.o

I run above command twice and preparing seems completed. Got
nvidia.o at /lib/modules/2.4.18-18.7.x/kernel/drivers/video/

I copied the nvidia.o into /usr/X11R6/lib/modules/drivers/

Then I run
#rpm -ivh NVIDIA_GLX-1.0-4191.i386.rpm

Preparnig [100%]
with 5 warnings

OK. edited /etc/X11/XF86Config-4

then I run
#startx

(EE) LoadModule:Module nvidia does not have a nvidiaModuleData data object
(EE) Failed to load module "nvidia" (invalid module, 0)
(EE) no drivers available

It seems failure at first place. but not sure what is the problem here and how can I fix the issue? Your helps will be appreciated,
-Hong

bwkaz 12-18-02 04:18 PM

nvidia.o is not an XFree86 driver!

It's a Linux kernel module, and should be in the /lib/modules/$(uname -r)/kernel/drivers/video directory. DO NOT MOVE IT.

When you say Driver "nvidia" in your /etc/X11/XF86Config(-4 if it exists) file, you are telling X to load the /usr/X11R6/lib/modules/drivers/nvidia_drv.o file. Not an nvidia.o, anywhere.

The reason you're getting an error seems to be that you've copied the kernel module into the XFree86 drivers directory, and for some reason, XFree86 is trying to load it instead of the proper file (the nvidia_drv.o file that comes from the NVIDIA_GLX package).

All you have to do is install the proper NVIDIA_kernel, then install NVIDIA_GLX, then edit your /etc/X11/XF86Config(-4 if it exists) configuration file, then restart X.

You don't really need to exit X if you don't have an older version installed.

honghsu 12-18-02 05:57 PM

thanks Kwkaz
 
Thanks for the response. However I got error when install following. What is wrong?

#rpm -ivh NVIDIA_kernel-1.0-4191.rh7xup_2.4.18-18.7.x.athlon.rpm


Got error message:
modprobe: Can't locate module nvidia
Failed to install nvidia.o



Thanks again,
-Hong

bwkaz 12-18-02 06:12 PM

Is that the file that NVchooser told you to download? I doubt it...

honghsu 12-18-02 07:51 PM

bwkaz,

No. The NVchooser.sh asks
NVIDIA_kernel-1.0-2960.rh73up.athlon.rpm and
NVIDIA_GLX_1.0-2960.i386.rpm

However, there are no such drivers available for downloading from www.nvidia.com

Where could be website for that download?


Thanks,
-Hong

bwkaz 12-18-02 09:31 PM

Use this NVchooser:

ftp://download1.nvidia.com/XFree86_4...1/NVchooser.sh

This is the NVchooser that's linked off the 4191 download page (that was where I got this URL). It will tell you to download release 4191, but the rest of it will match your kernel.

honghsu 12-20-02 10:41 AM

bwkaz,

thanks for your suggestion. The X windows works now after

#rpm -ivh NVIDIA_kernel-1.0-2960.rh73up.athlon.rpm and
#rpm -ivh NVIDIA_GLX_1.0-2960.i386.rpm and

edit /etc/X11/XF86Config-4

However, a new problem have me back to square one:

After insllation of network driver
#rpm -ivh NVIDIA_nforce-1.0-0248.rh73up_2.4.18_3.athlon.rpm

network work fine. Then I reboot machine. The network still work fine, but startx hang forever!

I found NVdriver has been unloaded! So I load it again. The startx still hang forever.

Then I rpm -e two NVIDIA_kernel-1.0-2960 and NVIDIA_GLX_1.0-2960

and reinstall these two and edited XF86Config-4 again.
The #sh nv_check.sh says OK.
#lsmod says NVdriver and nvnet OK.

At this stage, the #startx still hang forever. What could be problem here? Does anyone has same experience and could share with me. Maybe the NVIDIA_nforce-1.0-0248.rh73up_2.4.18_3.athlon.rpm conflits with video drivers.

-Hong

Wolfman [TWP] 12-20-02 10:48 AM

For the sake of curiosity, have you run Xwindows, without installing the NVidia kernel drivers, but only the Nforce ones??

honghsu 12-20-02 11:09 AM

Before installation of NVdriver and nvnet, the X windows didn't work at all. After load MVdriver, startx works! after installation of nvnet through XTerm, the network card works, and X application also work. BUT after reboot, X windows stops working!

Wolfman [TWP] 12-20-02 11:14 AM

Looks like a problem for Nvidia to fix..

honghsu 12-20-02 11:31 AM

Does that means no one has Asus A7N266-VM motherboard work for both X windows and network card so far on kernel 2.4.18-3?

Hmm,

honghsu 12-20-02 08:14 PM

bwkaz, update
 
Well, I removed nvnet module and uninstall the NVIDIA_nforce-1.0-0248.rh73up_2.4.18_3.athlon.rpm, the X windows still hang forever.

I removed NVdriver and uninstalled two corresponding rpms, and reinstall the two rpms. Same problem: X windows hang forever!

Then I UNPLUGED ZIPDRIVE from USB port. I notived the NVdriver is unloaded every time the machine booted. Would someone tell which config file is responsible for unloading the NVdriver?

I ADDED /sbin/insmod -f NVdriver at the end of /etc/rc.local

The X windows back to work! At this point, I installed NVIDIA_nforce-1.0-0241.rh73up.athlon.rpm instead of previous 0248 rpm. The network back to work!

So far both X windows and network work fine. I guess the pluged zipdrive and configuration of the Northbridge and Southbridge cause A7N266-VM failed, but don't know what were failed exactly. Could someone point out how to trace the problem?

Hope the workaround could help others. Thanks bwkaz,


All times are GMT -5. The time now is 12:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.