nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   glu library - solaris 10 x86 (http://www.nvnews.net/vbulletin/showthread.php?t=54447)

Lumer 08-01-05 09:57 AM

glu library - solaris 10 x86
 
I can't find the glu library or glu.h for solaris 10 x86.

I've installed the NVIDIA 1.0-7667 drivers, but the libGLU doesn't seem
to be part of the installation according to the README.

Is there an optimized libGLU available?

There are quite a few OpenGL apps that rely on libGLU, so I'm kind
of baffled as to why this is missing.

Thanks.

ctilburg 08-04-05 12:20 PM

Re: glu library - solaris 10 x86
 
Nvidia points out that the GLU library is not part of thier
driver dist... it is part of Xorg. This problem is Sun's fault.

ctilburg 08-04-05 02:49 PM

Re: glu library - solaris 10 x86
 
glxinfo, glxgears, and libGLU.so.1 are available for Solaris 11
svn 19, on cd #2, in the cpio file:

Solaris_11/Product/SUNWxorg-mesa/archive/none.bz2

I extracted the files with cpio and copied only what was needed to
/usr/openwin/bin, /usr/openwin/bin and /usr/X11R6/lib, respectively.

At least, glxinfo and glxgears work at this stage under Solaris 10 x86.

It would appear that glut will have to be built from network sources as
it is not included in the xorg packages... freeglut 2.4.0 is the current
stable version as of this posting.

ADDITIONAL:

1: don't forget to make the symlink libGLU.so -> libGLU.so.1 or linking
will have troubles.

2: I suppose the glu.h header file is buried in their cpio xorg packages
as well, but copying over the one resident on my FC4 linux system
worked just fine for me.

3: build freeglut with sun's compiler (take them up on the free studio
compiler offer when you grab Solaris 11). The gcc 3.4.2 or 3.4.3 that
gets installed fails mysteriously on some file involving joysticks.

4: use 'gar' for 'ar' manually when the build dies, then just take the libs
you need from the .libs directory. Or just take the .so and note the
symlinks needed if you don't need the static library.

johnmartin 08-16-05 02:54 PM

Re: glu library - solaris 10 x86
 
Summary:

libGLU and headers are included in Solaris releases that
include the SUNWxorg-mesa package.

If you are using a Solaris release that does not yet have the
SUNWxorg-mesa package you can grab this version:

http://home.comcast.net/~jdmartin99/SUNW0glutil.tar.gz

Note: the libGLw in this image will be binary incompatible with
what gets eventually bundled in Solaris. (GLU is fine).


Also, GLUT is available at:

http://www.opengl.org/resources/libr...loads.html#sun

stottle 10-01-06 09:17 PM

Re: glu library - solaris 10 x86
 
All,

I'm running the 0606 version of Solaris and the most recent (downloaded today after an older version didn't work) nvidia driver. I also have the problem where the glu.h file isn't found. I'm trying to compile gtkglext, which says it requires opengl or mesa. I thought the nvidia drivers would install opengl, but this header/library is missing. I tried the links attached, but they no longer work...

I am familiar with solaris, but I'm using my own computer and I'm a noob at solaris sysadm, so I struggling with this. This is the first link I've found that doesn't point to mesa, and gtkglext says it needs either, not both, mesa or opengl.

I would really appreciate some help getting glu.h and the associated files loaded for solaris.

TIA,
Brett


All times are GMT -5. The time now is 09:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.