nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   can't get rpms to work in Red Hat 8 (http://www.nvnews.net/vbulletin/showthread.php?t=5514)

faughp 12-23-02 03:59 PM

can't get rpms to work in Red Hat 8
 
I thought I followed everything by the book, but I still can't get it to work. overview:
downloaded and ran NVchooser
downloaded NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0.i686.rpm
and NVIDIA_GLX-1.0-4191.i386.rpm.
tried to install, and got
modprobe: can't locate module nvidia
Failed to install nvidia.o
installed the GLX, and tried to startx, which promptly didn't work, since I think I've got 2.4.18-14.
Then I downloaded and compiled NVIDIA_kernel-1.0-4191.src.rpm
tried to uninstall NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0.i686.rpm, and it told me that it wasn't installed.
Then tried to run the rpm created after compiling, and it told me that there was a newer version installed (the one that I tried to uninstall!) I think I'm in a catch-22 here. I know I messed up, but can't seem to fix it!
This was a new install of Red Hat 8.0, on a new hard drive, set up as a dual boot. can someone tell me how to fix this? thanks. paul
and yes, I'm new to linux.

Andy Mecham 12-23-02 07:46 PM

What's the output of 'uname -r'? NVchooser.sh may have given you the wrong RPM to install. If so, please contact me via PM so I can get a bug report from you.

To uninstall an RPM, you have to pass the exact name listed in the RPM database. This doesn't always match the actual name of the RPM. (annoying, isn't it?) To figure out what the name is, you can run 'rpm -qa | grep "NVIDIA_kernel"'. If the RPM you installed is the only one returned, then you can either cut and paste the result to 'rpm -e *RESULT*', or do 'rpm -qa | grep "NVIDIA_kernel" | xargs rpm -e'.

Once the 2.4.18-18 RPM is uninstalled, you should be able to install the one you rebuild yourself.

-andy

faughp 12-23-02 11:08 PM

Made the changes as recommended, & after editing the XF86Config file, all is working. Thanks!

Wolfman [TWP] 12-24-02 07:38 AM

When I update the Nvidia drivers, I usually run rpm -e NVIDIA_GLX, then
rpm -e NVIDIA_kernel.

(You have to run it that way due to dependancies).

I found that you can use the '--force' at the beginning to force it to install the driver. (But I kind of find that very messy)


All times are GMT -5. The time now is 01:08 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.