nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   New Redhat Beta Phoebe (http://www.nvnews.net/vbulletin/showthread.php?t=5547)

Elay 12-24-02 03:45 PM

New Redhat Beta Phoebe
 
I just want to try the new beta from Redhat. Hmm They polished the product a bit. Now it includes a nice mouse scheme by default.

Anyway here comes the problem. I tried to install the NVIDIA drivers 4191. And at the first time it installed succesfully but when i tried to start X it went away saying that it get Sig 11 when calling GLXExtensions. Hmm then I tried to remove the "Load glx" from the XF86Config. Bingooo, it simply started, but of course I could not have the OpenGL this time. Then I tried the 3123 and 2802 drivers. But nothing changed in the situation. Did not try the 2880 however.

Ok. Which has the problem? NVIDIA Drivers or the beta X server or me ??? How can I solve the situation? :confused:

bartszyszka 12-24-02 04:49 PM

I wasn't able to get the nvidia driver working with Pheobe (got the same GLX error) until I read your message here and disabled GLX in XF86Config. Right now the only problem I'm experiencing as far as X goes is that it's extremely difficult moving things across the Nautilus background because they take forever to repaint. Is this related to the OpenGL thing being disabled? Before this I was running the latest RH 8.0 beta upgraded to the lated RH 8.0 final and am thinking of just getting the latest RH 8.0 ISOs (as much as I love the new Phoebe curors...) unless there's a way to get this thing working better.

Elay 12-25-02 03:02 AM

Quote:

Originally posted by bartszyszka
Right now the only problem I'm experiencing as far as X goes is that it's extremely difficult moving things across the Nautilus background because they take forever to repaint. Is this related to the OpenGL thing being disabled?
Well I dont have the source code but I think that some X functions and/or X extensions must be related with the NVIDIA GLX library. But dont take my word for it, it is just a guess. Well I realized that my windows movements are a bit slower without GLX. Anyway I hope it will be solved.

DaMaxx 12-25-02 11:43 PM

mmmm redhat gooood. hehe

find any stablilty issues with phoebe?

Wolfman [TWP] 12-27-02 09:36 AM

So I take it that downloading the src.rpm's and recompiling them didn't help?? (Just a thought) :)

Karzak 12-30-02 05:46 AM

more info - phoebe (redhat linux 8.0.92)
 
components:

kernel/glx driver version 1.0-4191
kernel version 2.4.20-2.2

Xfree86:

XFree86-devel-4.2.99.2-0.20021217.0
XFree86-Xvfb-4.2.99.2-0.20021217.0
XFree86-libs-data-4.2.99.2-0.20021217.0
XFree86-truetype-fonts-4.2.99.2-0.20021217.0
XFree86-xauth-4.2.99.2-0.20021217.0
XFree86-xdm-4.2.99.2-0.20021217.0
XFree86-twm-4.2.99.2-0.20021217.0
XFree86-xfs-4.2.99.2-0.20021217.0
XFree86-4.2.99.2-0.20021217.0
XFree86-75dpi-fonts-4.2.99.2-0.20021217.0
XFree86-libs-4.2.99.2-0.20021217.0
XFree86-base-fonts-4.2.99.2-0.20021217.0
XFree86-tools-4.2.99.2-0.20021217.0
XFree86-font-utils-4.2.99.2-0.20021217.0
XFree86-Mesa-libGLU-4.2.99.2-0.20021217.0
XFree86-100dpi-fonts-4.2.99.2-0.20021217.0


X server log output:

(II) [GLX]: Initializing GLX extension

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting

strace on X server (part of it):

2403 write(0, "Loading extension NV-CONTROL\n", 29) = 29
2403 ioctl(7, 0xc0104648, 0xbffff90c) = 0
2403 ioctl(7, 0xc0104648, 0xbffff8f8) = 0
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 40) = 40
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 48) = 48
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 38) = 38
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 42) = 42
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 36) = 36
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 44) = 44
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 41) = 41
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 41) = 41
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 48) = 48
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 39) = 39
2403 write(0, "(II) ", 5) = 5
2403 write(0, "Initializing built-in extension "..., 38) = 38
2403 gettimeofday({1041247993, 328736}, NULL) = 0
2403 write(2, "(II) [GLX]: Initializing GLX ext"..., 39) = 39
2403 write(0, "(II) [GLX]: Initializing GLX ext"..., 39) = 39
2403 brk(0) = 0x83d2000
2403 brk(0x83d3000) = 0x83d3000
2403 modify_ldt(17, {entry_number:0, base_addr:0x83d1fd8, limit:512, seg_32bit:1, contents:0, read_exec_only:
0, limit_in_pages:0, seg_not_present:0, useable:1}, 16) = 0
2403 open("/dev/nvidiactl", O_RDWR) = 8
2403 ioctl(8, 0xc1404602, 0x401320e0) = 0
2403 ioctl(8, 0xc0144606, 0xbffff860) = 0
2403 ioctl(8, 0xc00c4622, 0xbffff87c) = 0
2403 --- SIGSEGV (Segmentation fault) ---
2403 rt_sigaction(SIGSEGV, {SIG_IGN}, {0x8083670, [SEGV], SA_RESTORER|SA_RESTART, 0x42027988}, 8) = 0
2403 write(2, "\n *** If unresolved symbols we"..., 112) = 112
2403 futex(0x42122148, FUTEX_WAKE, 1, NULL) = 0
2403 write(0, "\n *** If unresolved symbols we"..., 112) = 112
2403 futex(0x81fe428, FUTEX_WAKE, 1, NULL) = 0
2403 write(2, "\nFatal server error:\n", 21) = 21


what is annoying is that I cannot downgrade to XFree version 4.2.0 because that provides libXft.so.1 and all the stuff after the upgrade requires libXft.so.2...

Karzak 12-30-02 04:13 PM

fix or something
 
i switched kernel to 2.4.18-19 (latest update from redhat 8.0) and no more SEGV from X.
however, as will a lot of redhat betas, things got out of hand after.. suddenly my mouse stopped working in quake; altough 3d accel was ok, when i tried to move a window across the screen it was sluggish as hell; and finally the whole rpm database got corrupted or something (and no, it was not about the __db files :( ).

so i reinstalled 8.0 standard. :)

tinus 02-25-03 04:52 AM

Found this on the phoebe mailing list:

https://listman.redhat.com/pipermail...ry/001978.html

' Sounds to me from
reading the bugticket like is yet another threading related bug inside
that 3rd party xmms plugin. Goes away if you use
LD_ASSUME_KERNEL=2.2.5.'

Amazingly, the glx problem also disappears if you define this. I put it in /etc/X11/prefdm:

LD_ASSUME_KERNEL=2.2.5
export LD_ASSUME_KERNEL

This makes the X server start.

Now you also need to put this in your .profile, otherwise any glx program you run wil also crash.

rebus 03-04-03 04:05 AM

Re: New Redhat Beta Phoebe
 
Quote:

Originally posted by Elay

Anyway here comes the problem. I tried to install the NVIDIA drivers 4191. And at the first time it installed succesfully but when i tried to start X it went away saying that it get Sig 11 when calling GLXExtensions.

Ok. Which has the problem? NVIDIA Drivers or the beta X server or me ??? How can I solve the situation? :confused:

Problem is in both.
Here are the src.rpms you are looking for and small guide how to use it:
http://rebus.webz.cz

If it does'n work, feel free to mail me.

Michal Ambroz


All times are GMT -5. The time now is 09:46 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.