nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   A Newbie's Question (http://www.nvnews.net/vbulletin/showthread.php?t=5592)

winghong 12-26-02 03:27 AM

A Newbie's Question
 
My linux is Slackware 8.0. When I install the drivers, errors occur.

root@polaris:/# rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_kernel-1.0-4191.i386.rpm
error: failed dependencies:
kernel >= 2.2.0 is needed by NVIDIA_kernel-1.0-4191
rpm >= 3.0.4 is needed by NVIDIA_kernel-1.0-4191
/bin/sh is needed by NVIDIA_kernel-1.0-4191
/bin/sh is needed by NVIDIA_kernel-1.0-4191
/bin/sh is needed by NVIDIA_kernel-1.0-4191

root@polaris:/# rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_GLX-1.0-4191.i386.rpm
error: failed dependencies:
XFree86 >= 4.0.1 is needed by NVIDIA_GLX-1.0-4191
NVIDIA_kernel is needed by NVIDIA_GLX-1.0-4191
kernel > 2.2.0 is needed by NVIDIA_GLX-1.0-4191
/bin/sh is needed by NVIDIA_GLX-1.0-4191
/bin/sh is needed by NVIDIA_GLX-1.0-4191
/bin/sh is needed by NVIDIA_GLX-1.0-4191
ld-linux.so.2 is needed by NVIDIA_GLX-1.0-4191
libX11.so.6 is needed by NVIDIA_GLX-1.0-4191
libXext.so.6 is needed by NVIDIA_GLX-1.0-4191
libc.so.6 is needed by NVIDIA_GLX-1.0-4191
libdl.so.2 is needed by NVIDIA_GLX-1.0-4191
libm.so.6 is needed by NVIDIA_GLX-1.0-4191
libc.so.6(GLIBC_2.0) is needed by NVIDIA_GLX-1.0-4191
libdl.so.2(GLIBC_2.0) is needed by NVIDIA_GLX-1.0-4191
libdl.so.2(GLIBC_2.1) is needed by NVIDIA_GLX-1.0-4191

However, I have checked that my configuration is kernel 2.2.19, rpm 4.0.2 and /bin/sh is found.

etr 12-26-02 11:43 AM

OK, this would be a Slackware-specific issue. You should probably use the tarballs instead of the RPM's. RPM's record a number of dependencies on other RPM's. These dependency checks include such basic packages as the one used to install /bin/sh. Because Slackware does not user RPM's to install it's components (such as /bin/sh and X), RPM will fail the dependency checks for the nVidia drivers.

You have two options: you can install the drivers from a tarball instead of using the RPM's, or you can ignore RPM's failed dependency checks. I recommend using the tarballs--if there is something missing, it will probably be easier to dig in and find out what the problem is with a tarball than with a RPM. However, if you have checked all the dependencies and feel confident you have everything, you can tell RPM to ignore failed dependencies. I believe the option for this is "--no-deps", but check the man page.

Good luck!

volt 12-26-02 12:07 PM

get tarball version...compiled without problem here.

winghong 01-01-03 10:04 PM

Thank you for your help. But when I use the .tar file, errors again.

ld -r -o nvidia.o nv-linux.o nv-kernel.o
size nvidia.o
text data bss dec hex filename
1247691 92856 32908 1373455 14f50f nvidia.o
depmod: *** Unresolved symbols in /lib/modules/2.2.19/video/nvidia.o
/lib/modules/2.2.19/video/nvidia.o: unresolved symbol __global_cli
/lib/modules/2.2.19/video/nvidia.o: unresolved symbol tqueue_lock
/lib/modules/2.2.19/video/nvidia.o: unresolved symbol __global_save_flags
/lib/modules/2.2.19/video/nvidia.o: unresolved symbol __global_restore_flags
/lib/modules/2.2.19/video/nvidia.o: unresolved symbol smp_num_cpus
/lib/modules/2.2.19/video/nvidia.o: insmod /lib/modules/2.2.19/video/nvidia.o failed
/lib/modules/2.2.19/video/nvidia.o: insmod nvidia failed
make: *** [package-install] Error 255

This is the kernel file. The NVIDIA_GLX-1.0-4191 file compiles without error.

Imperito 01-02-03 01:34 AM

You are using a 2.2.x kernel?

...

Does the driver you got support that?

winghong 01-07-03 01:15 AM

But it said,

kernel >= 2.2.0 is needed by NVIDIA_kernel-1.0-4191
rpm >= 3.0.4 is needed by NVIDIA_kernel-1.0-4191

So, if this latest version is not okay, any other version I can use?

Wrawrat 01-07-03 07:06 AM

Here are the requirements from the README:

o linux kernel 2.2.12 # cat /proc/version
o XFree86 4.0.1 # XFree86 -version
o Kernel modutils 2.1.121 # insmod -V

If you need to build the NVIDIA kernel module:

o binutils 2.9.5 # size --version
o GNU make 3.77 # make --version
o gcc 2.91.66 # gcc --version

If you build from source rpms:

o spec-helper rpm # rpm -qi spec-helper

Make sure you have them!

winghong 01-14-03 05:38 AM

I have checked my configuration as,

cat /proc/version 2.2.19
XFree86 -version 4.1.0
insmod -V 2.4.6

size --version 2.11.90.0.19
make --version 3.79.1
gcc --version 2.95.3

but no spec_helper installed. These fulfill all the requirements for building the .tar files.

but I notice that the XFree86 command cannot be used explicitly. I need to go to the /usr/X11/bin to issue ./XFree86 -verion. So, is there any problems in the setting of path?

Thank you for your attention.

Sir_J77 01-14-03 05:03 PM

I had this very same problem about a year ago, and all anyone could tell me was "read the readme" was was part of the problem.
They don't seem to know what they are talking about or is an old readme they never updated. Here is my notes...

Video (geforce2)
Working version, 2.4.5 and XFree86 4.2.0 (slackware packages, tgz)
-
From /usr/src/linux-version/ type make menuconfig
Go to processors and disable SMP.
-
As root, and where kernel driver and glx driver are located type
make install
-
In /etc/rd.d/rd.modules add the following...

/sbin/modprobe NVdriver
/sbin/modprobe agpgart

That should at least get you close. I don't know why agp won't work with 2.2.19, but I beat my head on it for about a month, and as last desperate act, I reinstalled with 2.4.5 and d/l xfree 4.2.0. Shotguning it like that seemed to do that trick.
Hope it helps. I need to make it work myself with Slackware 8.1 soon, so maybe I'll come up with another tidbit of info.
Peace


All times are GMT -5. The time now is 06:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.