nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce Go 6600 freezes system when running OpenGL apps (http://www.nvnews.net/vbulletin/showthread.php?t=56143)

quetzyg 09-06-05 03:21 PM

GeForce Go 6600 freezes system when running OpenGL apps
 
At first, I tough it was a hardware problem (ie. high temperature), but now I know that the system freezes completely because of the drivers. The most unstable when running 3D apps, are the latest (7676). If I use the 7667, or the 7664, the system gets more stable, and doesn't freeze too often (but it still does sometimes).


And another thing!
nvidia-settigs segfaults when I try to run it. I think that, it begun to do that, since I upgraded from GLib 2.6.x, to 2.8.x. Any other ideas?

Here are my laptop specs:

Code:

CPU: Centrino 2.0GHz (Alviso)
Chipset: Intel 915G (ICH6M)
RAM: 2GB DDR2
GPU: GeForce Go 6600 256MB

.
I'm running Slackware 10.1 with Linux 2.6.13.

Cheers,
Quetzy Garcia

kmare 09-06-05 04:25 PM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
about nvidia-settings.. try to recompile tha package..

quetzyg 09-07-05 03:14 AM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
I already did. I think I'm gonna downgrade from Gtk 2.8.x to 2.6.x. That should fix it.

quetzyg 09-07-05 04:36 AM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
It's official, Gtk 2.8.x segfaults nvidia-settings!

zander 09-07-05 04:55 AM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
I doubt it's a general incompatibility, GTK 2.8.x is binary compatible with earlier GTK+ releases and `nvidia-settings` works fine for me with GTK+ 2.8.3. What does the call trace look like when you run `nvidia-settings` from `gdb`? Also, does the problem go away if you build `nvidia-settings` from source (against the GTK+ 2.8.x release you have installed on your system)?

quetzyg 09-07-05 03:26 PM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
Well, I downgraded to Gtk+2.6.10, so I can't tell you about it right now. And, about the system freeze while running 3D apps, does anyone have similar problems? If more info is needed, just ask.

quetzyg 09-10-05 06:59 AM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
Today came out the 2.6.13.1 version of Linux. I'm running it along with the latest NVidia drivers (7676), and it seems to be working fine so far, without freezing the system while playing Enemy Territory.

quetzyg 09-10-05 04:23 PM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
ARGH! I spoke too soon, the problem persists :mad:

Dellusionary 09-12-05 05:30 AM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
:confused: Quetzyg, I left Doom 3 running in demo mode for a couple of hours today to see if it would crash, but it didn't. Not sure what's different (except I've got the 6800 card), but here's my setup for your info:

Kernel 2.6.13 vanilla (kernels before 2.6.12 gave me probs), KDE 3.4.2, using Debian Unstable, 7667 NVIDIA drivers with no modifications, wifi (IPW2200 drivers .. buggy but working), latest X11... only thing I've been doing I've only compiled into the kernel what I actually use and what's pluggable, and I minimized the number of modules made. I run old, stable versions of software whenever I can get away with it. I'll spend some time trying to fry the thing with more 3D apps next chance I get.

Since I upgraded the kernel (the day it came out) I've not had any programs crash (except Synaptic but that's a known issue). But I have no doubt when there finally is suspend support in ACPI I'll be needing some more aspirin for a new lot of headaches :p .

quetzyg 09-12-05 07:02 AM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
At the moment, I'm using Linux 2.6.13.1 on Slackware 10.1, gcc 3.3.4, 7676 NVidia drivers, X.org 6.8.1, IPW2200 1.0.6 drivers, Fluxbox 0.9.13. The only thing that I see diferent on your configuration, besides the graphic card model (and the drivers, but I try them all), is the X11 and the window manager. I don't think Fluxbox has anything to do with the crashes, so I supose it may be X (by being a bit old?). I'm going to upgrade to X.org 6.8.2 to see if get best results.

Cheers,
Quetzy Garcia

quetzyg 09-12-05 01:04 PM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
Well, I don't know what to try more. Using X.org 6.8.2 didn't help either. :(

Dellusionary 09-12-05 09:24 PM

Re: GeForce Go 6600 freezes system when running OpenGL apps
 
Quote:

Originally Posted by quetzyg
At the moment, I'm using Linux 2.6.13.1 on Slackware 10.1, gcc 3.3.4

Ok, I have gcc 4.0.1 - that's something i should have mentioned! Can be a pain to change over to it though.


All times are GMT -5. The time now is 05:39 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.