nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   OpenSuse 10.0 RC1 - nvsound - nightmare (http://www.nvnews.net/vbulletin/showthread.php?t=56452)

interzoneuk 09-12-05 05:34 PM

OpenSuse 10.0 RC1 - nvsound - nightmare
Hi People.

I have just installed opensuse 10.0 RC1 (btw.. it looks like its going to be great when its finished).

After installing the latest (1.0-0306) nforce driver and doing the changes to /etc/modprobe.d/sound, after reboot I am unable to use my mouse or speedtouch usb adsl modem (suggesting that some how USB has died)

If I undo the changes to /etc/modprobe.d/sound (i.e - not using the nvsound driver)
and reboot the mouse and speedtouch modem works again

Any ideas?

Here are my specs:-
kernel - 2.6.13-9
Motherboard : Nforce 2 - Asus A7N8X-E Deluxe BIOS 1013

netllama 09-12-05 05:37 PM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
Please generate a bug report (nforce-bug-report.log).


interzoneuk 09-13-05 01:26 PM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
How do I generate a bug report?

netllama 09-13-05 01:31 PM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
Per the release notes that ship with the driver, you run nforce-bug-report.sh as root.


interzoneuk 09-13-05 02:30 PM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
Thank you , I have sent a bug report.

BTW I have tried the driver on the following Distros and it works fine.

Mandrake 10.1
Suse 9.3
Kubuntu (Hoary)

interzoneuk 11-29-05 06:28 AM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare

Am still having the same problem.

Now with Super opensuse 10 and 1.0-03010 driver.

As soon as I install the driver and do the changes to /etc/modprobe.d/sound and reboot my system randomly locks up, also I lose control and the mouse.

Has anyone ANY ideas of how I can fix this, not having the nvsound driver working is the only thing stopping me from using Super opersuse 10 as my main system

(Btw super opensuse is the faster OS i have used - Openoffice 2 opens (from cold boot) in 3-4 secs)

warlock_ba 11-29-05 08:18 AM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
Here is a hint. I don't really know the Suse module architecture, and I hope it's not too different from fedora, do the following:

look in /etc for a file called modprobe.conf.dist
If there is one, then include it in modprobe.conf:
"import /etc/modprobe.conf.dist"
Same thing heapened to me, as the Nvidia driver breaks the default dependency table of the system, if the above mentioned file isn't included.

netllama 11-29-05 11:13 AM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
At what stage is your system locking up? How far in the boot process does it get?

If you revert the changes to /etc/modprobe.d/sound and just run 'modprobe nvsound' does that work?

Also, please generate and post an nforce-bug-report.log.


interzoneuk 12-05-05 07:39 AM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
Hi netllama.

Thanks for the response.

The strange thing is is that is stops at random times during boot, can we whilst loading network interfaces, USB or random number generator, it stops seemingly at random.

Here are some more strange things regarding this problem.

1> It occasionally does fully boot up (i would say about 1 in 10 chance of booting), if it does there seems to be about 50/50 chance that the mouse works - it sometime does and sometimes doesn't.
- this is after doing no changes.

2> If I try to uninstall the driver (./NFORCE.... --uninstall) it tells me that no driver is installed.

I can undo the changes (ie not load nvsound and load alsa) and the system is 100% rock solid stable.

I really want to fix this (as I have said before this issue is the only thing holding me back from using Super SUSE as my 1 and only desktop -- no more Windows..)

If anyone has anything they can think of that can help me sort this I would be very greatful.


netllama 12-05-05 10:09 AM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
From your description, it sounds like there's some kind of race condition.

If you just run 'modprobe nvsound' does sound work, and is the system functional?

Also, please post an nforce-bug-report.log.

Do you have a hard requirement to use 'Super SuSE' instead of the standard SuSE-10.0 ? I'd be curious whether this reproduces in SuSE-10.0 as well.


interzoneuk 12-05-05 02:07 PM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare
HI netllama.

If the system does actually boot then the sound works no problem...

The problem is the same as my original post (using Suse RC1 and 3-06) so it appears that the problem would exist in normal SUSE 10 for me.

Have already posted bug report.

I know its a wierd problem, almost windows like(i.e it is really hard to see what is causing the problem)

interzoneuk 12-12-05 05:23 AM

Re: OpenSuse 10.0 RC1 - nvsound - nightmare

I have some more info regarding this.

the problem is something relating to opensuse, I have tried the following systems

Mandriva 2006
Kubuntu 5.10
Fedora 4

The driver works on the same machine.

I have also found it is not the opensuse kernel, as I have used the exact same kernel for kubuntu and suse ( this was the vanila kernel with ck6 patches from here - http://www.ubuntuforums.org/showthread.php?t=84174) BTW this is a great guide for recompiling a vinilla kernel with paches.

The kernel worked fine on both Kubuntu and Suse, however when I install nforce driver on Kubuntu my system works fine , whilst on Suse I get the crashing/locking up problem (this is on the same system).

Any other ideas?

All times are GMT -5. The time now is 06:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.