nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia Driver Rpm Question (http://www.nvnews.net/vbulletin/showthread.php?t=576)

Big Booger 08-10-02 07:57 AM

Nvidia Driver Rpm Question
 
I am a Linux Noob, been using it for about 4 days now.
Running Mandrake 8.2
System:
Celeron 533mhz
256MB PC133 Ram
15 GIG HDD
AGP ASUS Geforce2ti 7700 64MB DDR RAM
etc...

No problems at all, really. Just the MorphGL screensaver runs like ballz. Anyway I have just a few questions:

One,
How do I check to see if I have the updated 29.60 Linux drivers installed? I used the RPMs from http://www.nvidia.com
The RPM installation went off without a hitch. I got the congratulations message on both installations. Now how can I tell I have them installed.
When I check the mandrake control center I get a message like this:
Quote:

Vendor: Nvidia Corporation
Model: Geforce DDR (generic) NV15 DDR (Geforce 2 GTS)
BUs Type: PCI
So I guess my question is am I up to date. I am think that the NV should say 29 as in NV29 DDR but I may be wrong...

If I am not up to date what steps should I take to resolve this issue.

Thanks for understanding and helping out a noob.
BB

Big Booger 08-10-02 09:38 AM

1 Attachment(s)
Guess I should post a few things concerning my installation. I am using KDE as my windows viewer.

Attached is a copy of the installation txt of my NVIDIA DRIVER using the rpm.
Please help if you can. I just want to know if I have installed it correctly.
Thanks
BB

Thunderbird 08-10-02 10:47 AM

That mandrake control center reads the card info from for example /proc/pci. It doesn't know anything about the nvidia drivers. To get the version of the drivers do: cat /proc/driver/nvidia/version.

Big Booger 08-10-02 11:27 AM

the only thing in the driver directory is a RTC file....
So what do I do now?
Thanks for the reply btw.
BB

r2d2d3d4d5 08-10-02 01:21 PM

Are you updating from a previous version of the nvidia drivers or from the mandrake drivers?
If you've updated from a previous version of the drivers did you uninstall the old ones first?
Did you edit your XF86Config-4 file as per the instructions in the manual?
Do you get the nvidia splash screen during loading of the OS.
Does your XFree86.0.log file report any errors?

Thunderbird 08-10-02 01:58 PM

You don't have to do anything. Likely the drivers are correctly installed. The way to check the kernel version is to use the command I told you. (cat /proc/driver/nvidia/version)

Big Booger 08-10-02 10:33 PM

Just updating the stock drivers from the Mandrake 8.2 installation. I recently tried to install the tar files from the Nvidia site, and it generated many many errors...
I haven't touched the XF86Config-4 file. Do you mind going over how to do that? Do I just open it in an editor and edit the file?

What should I edit? What values etc....

My monitor is displayed at 1024X768 85Hz 32bit mode
I just wished I could tell what driver I have installed. Also, is there an advanced properties for the Nvidia adapter like in windows?
I would like to tweak it a bit if possible.

Thunderbird,
Well I have tried both as a user and as root to run the cat /usr/proc/driver/nvidia/version
but it always generates an error. I then did a locate for the word nvidia, and it doesnt show up.
Then I manually entered the usr/proc/driver directory, and the only file in that directory is a RTC file... Is that strange? Does that mean my Nvidia driver is not installed?
Thanks for you help thus far.

BB

Thunderbird 08-11-02 04:53 AM

Not: cat /usr/proc/driver/nvidia/version
but this: cat /proc/driver/nvidia/version

Big Booger 08-11-02 07:33 AM

proc/driver/nvidia/version doesn't exist. Perhaps the driver is not installed?
BB

Thunderbird 08-11-02 09:32 AM

Post your (/etc/X11/)XF86Config-4 file. I think it isn't correct.

Big Booger 08-11-02 09:47 AM

1 Attachment(s)
Thunderbird thanks alot for your help. People like you make boards. I am very grateful.
BB

Thunderbird 08-11-02 10:34 AM

The problem is very easy, you forgot to add a line:
Load "glx" to the module section of the XF86Config-4 file and you forgot to change "nv" to "nvidia" in the device section of the XF86Config-4 file. After you change that it should work.


All times are GMT -5. The time now is 06:14 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.