nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   lockup and ascii junk with startx (http://www.nvnews.net/vbulletin/showthread.php?t=5830)

redmoose 01-01-03 11:02 PM

lockup and ascii junk with startx
 
1 Attachment(s)
When I type startx from the console the screen will flicker a few times then lockup with a screen that displays a bunch of different colored ascii junk and a red cursor block in upper left corner. The only thing that responds is ctrl + alt + delete.

This will only happen when APG is enabled, when Option "NvAGP" "0" is set it works fine, also with "nv" driver it will work. I have tryed both nvidia's agp and agpgart, both with same results.

My software is redhat 8.0 with kernel 2.18-18.8 , I have also tried the original redhat kernel, and the correct athlon 4191 drivers. They have been installed correctly. I have also upgraded to Xfree 4.2.1 with the same results. I have also tried the mem=nopentium boot option. I have had this problem for quite some time now and have seen it with mandrake 8.2, 8.0, and suse 7.2....

My hardware is a Duron 1.2ghz, PCCHIPS M810L (SiS730s chip), and a Geforce 3 ti 200 (64mb).

As for problem ideas, I am starting to think its a crappy motherboard. Ive heard some bad mouse configurations can also do things similiar to this but then again ive tryed starting x with that option to let x start if mouse fails. I am desperate to get AGP 4x goodness! Any suggestions/comments welcome.

I have attachedthe xfree logs from version 4.2.0 and 4.2.1.

redmoose 01-01-03 11:03 PM

1 Attachment(s)
and 4.2.1

redmoose 01-10-03 04:40 PM

waaa
 
no one has any ideas?

azerty 01-11-03 06:45 AM

No ideas, but at least i'll tell you that you're not the only one, i've the same problem with totally different configuration, (Athlon Via KT133 with Riva TNT2), and look at the post "please help", I think that it's the same issue, and even i found other older posts with same sympthoms, lockup at startx when AGP activated, and the log file truncated at the Initializing "xxxxxxx" mode line.
I've found no solution to this problem anywhere, I've tried the last Mandrake and Redhat distributions, and even I installed FreeBSD with its drivers, I've got the same sympthoms with all this configurations, It has to be a bug of the drivers that is present only with some hardware. I wrote to the Nvidia technician support by mail but I got no response. It's not a hardware fail becouse the AGP is working without any problems in W98.
Well, I suppose will have to wait Linux to be a majority O.S. to get fully supported drivers and tested with all kind of hardware...
:p

P.D: excuse me for the my english


All times are GMT -5. The time now is 07:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.