nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   No HDD-DMA with nForce 410 MCP (on Linux) (http://www.nvnews.net/vbulletin/showthread.php?t=58448)

zabex 10-20-05 10:46 AM

No HDD-DMA with nForce 410 MCP (on Linux)
 
I could not enable HDD-DMA on my new AsRock K8NF4G-SATA2.
hdparm -d1 /dev/hda
generates a
HDIO_SET_DMA failed:Operation not permitted
I tried Knoppix and compiled several Kernel (2.4, 2.6) with different options - no success
(yes, I enabled the IDE, nVidia Chipset support)

Could it be that the new nForce 410 is not compatible with current the Linux nVidia IDE support? Or do I just make a mistake? :confused:

Any help really welcome!

tabanus 10-21-05 04:30 AM

Re: No HDD-DMA with nForce 410 MCP (on Linux)
 
What distro are you using? DMA works fine for me in Gentoo, using kernel 2.6.13.

I don't have any SATA drives, and found that I had to disable SATA in BIOS to get things working though.

zabex 10-24-05 09:08 AM

Re: No HDD-DMA with nForce 410 MCP (on Linux)
 
Problem solved:
I was using Debian Kernel 2.6.8 which ist the highest kernel number you get when looking for "kernel-source" with apt-cache.
Now I found that I have to use "linux-source" instead.
So with "apt-get install linux-source-2.6.12" I've got a kernel that supports the DMA on my board! :)
So I was able to build my HDD-copy-machine. You may have a look at it on
http://www.dietmar-schroeder.de/hddcopy.html
(German text only)


All times are GMT -5. The time now is 01:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.