nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   K8N-DL won't boot Centos 4.1 after install (http://www.nvnews.net/vbulletin/showthread.php?t=59855)

dwynter 11-14-05 11:12 AM

K8N-DL won't boot Centos 4.1 after install

I am at a loss what to try next. I have installed Centos 4.1 8 times with different software RAID configs and the default disk partitioning. What gets me is it can instal just fine, obviously knows where the 4 SATA II disks on the nForce4 Pro controller are etc. But everytime I go to boot it just hangs after the "Verifying DMI Pool Data ..............." .

I am on bios revision 1007. I note that when I boot from CD it comes up with "Booting from the CD" or something similar. I expect that if attempting to boot from Disk it would display a similar message. So I am guessing that it is the nVidia nForce4 Pro that is the problem here.

I have disabled the nvRAID in the bios and the 3114 too. The 4 disks showup in the bios no problem. I know folk have used this motherborad successfully with bios revision 1006, maybe I should revert. From what I gather reading various forums NVidia don't give a damn about the Linux market, I should have researched this before buying 4 of these boards...




dwynter 11-14-05 11:39 AM

Re: K8N-DL won't boot Centos 4.1 after install
Well I reverted to bios version 1006, same result no boot. Man this is so frustrating.


dwynter 11-18-05 08:37 AM

Re: K8N-DL won't boot Centos 4.1 after install
After 25 or more installs of Centos 4.1 ( a community version of RHEL 4.1 so what is said here is true for that too I'd say ) I have discovered that the nForce4 Pro controller will not boot Linux. I can only assume that others who have this controller supporting a software RAID are booting off a PATA drive first.

I have successfully booted off the 3114 controller, only when the 4 SATA II Spinpoint drives are set up as a concatenated set.

I raised an issue with ASUS, they have not bothered to respond, seems they are not interested in other than Windows support. Lots of people need low cost databases servers, I thought mobos like the K8N-DL was the answer, I realise this is a mistake, I'd send my 4 of these back if I could.

I have to say the Intel 945G with the ICH7R is looking pretty attractive with a single 820D, lower cost and better support for RAID under Linux. At least they claim to support it (http://www.intel.com/support/chipset.../cs-020663.htm) which is a start.

So save yourself a world of pain if you want SATAII support with NCQ and choose a different motherboard to the ASUS K8N-DL.


dwynter 11-25-05 04:26 AM

Re: K8N-DL won't boot Centos 4.1 after install
Well amazing how ASUS has kept this quiet. After wasting 3 whole days trying to get this to work they answered my question after a 10 day delay. Simply sending me a list of known problems (which I had not found by googling for info on this problem). Here are the sections that relate to my K8N-DL:

Network and other devices randomly stop working when ACPI is enabled
This problem may be caused by an incorrect ACPI table entry that causes the timer interrupt to be incorrectly configured.
If the kernel console boot trace (viewable using dmesg) contains messages such as these:

..MP-BIOS bug: 8254 timer not connected to IOAPIC
...trying to set up timer (IRQ0) through the 8259A . failed.
...trying to set up timer as Virtual Wire IRQ... failed.
...trying to set up timer as ExtINT IRQ... works.

then the incorrect ACPI table entry is present. On 2.6 kernels, this can be worked around by specifying the 'acpi_skip_timer_override'
boot line option. An alternative workaround is to disable ACPI in the BIOS or by using the 'acpi=off' boot line option.

2.6.x kernel unbootable on some systems
There is a bug in the 2.6.x kernel MP table handling that prevents install and OS boot on some systems¹.
This bug causes memory corruption upon detection of any PCI bus numbered higher than 32, and consequently
renders the system unusable very early in the install or boot process. On some systems leaving ACPI on during
boot fixes this problem.

There are currently no known workarounds for this problem, but a kernel patch for it has been accepted and
is expected to be included in future distribution releases.

¹At the time of writing, the only nForce systems known to trigger this kernel bug are CK804 MP systems.

I hope this warns others off buying this motherboard if they intend to run a recent Linux.


firewoofer 11-25-05 11:19 PM

Re: K8N-DL won't boot Centos 4.1 after install
Funny thing, me and my team was just working with this board tonight, with centos 4.2. We had to upgrade our BIOS also to 1007, and we are using 200GB WD HD's. We were using the SIS sata ports for just straight sata/ But if you really want to use raid, i would just go with the 3ware cards for 2 ports it is only $135 extra, but for some of our cheap customers they don't want to spend that.. We will begin testing nvraid tomorrow, but our preliminary tests show linux seeing it as two drives and not 1 drive. Anyone have any howto's on how to get nvraid seen as 1 drive in linux or do we have to use dmraid?

All times are GMT -5. The time now is 08:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.