nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Inno3d 6600 AGP Problems (http://www.nvnews.net/vbulletin/showthread.php?t=60539)

tigger 11-26-05 12:18 PM

Inno3d 6600 AGP Problems
 
1 Attachment(s)
Hi All,

So having bought an Inno3d 6600 256Mb AGP 8x card, since installing it i have had no end of woe. I have tried the fllowing driver/kernel combinations

1. Ubuntu Breezy 'nvidia-glx' package, with nvidia driver 1.0-7667, kernel module 1.0-7667 and kernel version 2.6.12 with ubuntu patches (2.6.12-10-686-smp), resulting in a black screen upon starting X and being unable to chvt to the console. SSH'ing back in to find that XOrg is chewing cpu, and that I have the seemingly infamous 'Xid' bug, dmesg full of 'NVRM: Xid 6' and 'WAIT' in Xorg.0.log.

2. 2.6.14.3 with latest Nvidia drivers (1.0-7676) installed using the nvidia installer, same result, both with and without agpgart.

At this point i'm starting to get a bit peeved, so scouring these forums i find out that 1.0-8168 has leaked.

3. 2.6.14.3 w/ 1.0-8168 using nvidia installer. with and without agpgart. Same result 'Xid' and 'WAIT' and a blank screen.

Back to the forums and to google, to find the patch for 1.0-6629 to mke it compile against he latest kernel

4. 2.6.14.3 , 1.0-6629-patched , without agpgart in the kernel. Joy, i finally get a working X server, however i now discover 3 things:

i) /proc/nvidia/agp/status claims agp is disabled, despite having 8x supported in both the card and the host-bridge entriesin proc.

ii) /var/log/Xorg.0.log contains "(II) NVIDIA(0): Detected PCI Express Link width: 4X" , WHAT? i don't even have PCI-E ?! , also seeminlgy non-deterministicaly i get that line with 16X or 4X.

iii) any gl application chews 99% cpu, and crawls.

So now i'm stumped - is (ii) the root problem?, is (iii) a known symptom of (i) ? I've looked for newer bios's for my card, but the only Inno3d bios i could find is the revision i'm running.
Also - why is NVAGP not kicking in, given i have a purportedly supported chipset.

So here's the gory details of the setup:
Motherboard: Intel D865GLC
Memory: 2x512 PC333 (run under memtest, no errors)
CPU: 3.06GHz P4
Inno3d BIOS Version: 5.43.02.61
Xorg version: Ubuntu 6.8.2-77

Attached are my Xorg.conf / dmesg / Xorg.0.log / nvidia-bug-report.sh output

My next plan is to try replacing the inno3d biios with a different bios. whether this is a sane thing to try or not. I'm out of options.

Here's hoping someone's fixed this elsewhere, or has an idea what to try.

Ian

netllama 11-27-05 11:48 AM

Re: Inno3d 6600 AGP Problems
 
Are you using the latest BIOS for your motherboard?
Does this problem persist if you are not using RenderAccel ?

Thanks,
Lonni

tigger 11-28-05 04:24 AM

Re: Inno3d 6600 AGP Problems
 
Yup, this probem persisted with RenderAccel turned off, i turned it on to see if that boosted gl performance under the patched 1.0-6629 drivers. it was off for all other tests.
Also using the latest bios for the motherboard made no difference.

foodude2 04-22-06 09:12 PM

Re: Inno3d 6600 AGP Problems
 
You could read this http://www.nvnews.net/vbulletin/showthread.php?t=54452


All times are GMT -5. The time now is 09:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.