nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-8174 isntaller cannot determine kernel version (http://www.nvnews.net/vbulletin/showthread.php?t=61258)

Kether 12-08-05 06:27 AM

1.0-8174 isntaller cannot determine kernel version
 
1 Attachment(s)
When I try to install 8174 the installer complains it cannot determine my kernel's version to compile the nvidia kernel module. I tried to specify by hand the path to the kernel sources but there is no change.

In fact, when I tried to compile the module by hand (extracting the installer, and doing a simple "make install" in the appropiate directory) the compiler complained a bit, threw a few warnings, but the module compiled and installed. Finally I did a few dirty things to get the entire driver installed, although the installer problem is still there.

I'm using a custom kernel compile from debian's package linux-source-2.6.14 version 2.6.14-4. The kernel (and now the module) is compiled using gcc 4.0.3 20051201 (Debian package gcc-4.0 4.0.2-5). I think perhaps there is an issue with the compiler, but I don't want to recompile the entire kernel just to see if the installer works. And remember that "by hand" the module compile.

Also, as a note, 7676 installed with no problems at all with the same configuration.

Attached is my nvidia-installer log, if you need some of my kernel headers pelase tell me.

zander 12-08-05 07:45 AM

Re: 1.0-8174 isntaller cannot determine kernel version
 
This is a known problem, please see http://www.nvnews.net/vbulletin/show...00&postcount=2 for a patch that fixes it.

jtsai 12-08-05 02:37 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
I am also getting this problem on Red Hat Enterprise Linux WS release 3 (Taroon Update 4) 2.4.21-27.ELsmp.

Will there be a Linux-x86 version of this patch available soon?

zander 12-08-05 02:44 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
@jtsai: the patch isn't specific to either architecture; please note, however, that RHEL3 shouldn't be affected by this problem; if you're seeing this error, it's most likely legitimate. Please attach the /var/log/nvidia-installer.log file.

jtsai 12-08-05 03:22 PM

Re: 1.0-8174 installer cannot determine kernel version
 
1 Attachment(s)
Attached is my nvidia-installer.log

zander 12-08-05 03:34 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
@jtsai: judging from the log file, you're seeing a different problem; please install the kernel-source package for the running kernel.

jtsai 12-08-05 03:50 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
I'm a little confused how this is supposed to work.

Isn't this kernel version supposed to be pre-built into the installer? 2.4.21-27.ELsmp

The first error I get is:
No precompiled kernel interface was found to match your kernel

So because it couldn't detect my kernel version properly, the installer then tries to re-compile the kernel headers, which then subsequently gives the kernel-source error. But I shouldn't need to recompile.

In addition, I did try installing kernel-source, then used --add-this-kernel to compile the kernel headers from this machine into a custom package, and then re-run the installer, but it still complains again that "No precompile kernel interface was found to match your kernel."

zander 12-08-05 03:58 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
OK, I wasn't aware that you were trying to use the precompiled kernel interface for 2.4.21-27.ELsmp. Due to a bug in 1.0-8174's installer, some pre-compiled kernel interface files don't work; you appear to be affected by this problem. You can work around it by installing the kernel-source package for your kernel. If this is not an option, I can provide a fixed `nvidia-installer` binary for use with 1.0-8174.

netllama 12-08-05 04:08 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
Please provide the output from the following commands:
rpm -qa | grep kernel
ls -l /lib/modules/`uname -r`
cat /proc/version

Thanks,
Lonni

jtsai 12-08-05 04:14 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
[jtsai@rhdual10]~: rpm -qa | grep kernel
kernel-utils-2.4-8.37.7
kernel-source-2.4.21-27.EL
kernel-smp-2.4.21-27.EL
kernel-pcmcia-cs-3.1.31-13
kernel-2.4.21-27.EL
[jtsai@rhdual10]~: ls -l /lib/modules/`uname -r`
total 268
lrwxr-xr-x 1 root root 35 Dec 6 15:14 build -> ../../../usr/src/linux-2.4.21-27.EL
drwxr-xr-x 8 root root 4096 Dec 6 15:14 kernel
-rw-r--r-- 1 root root 52471 Dec 8 12:14 modules.dep
-rw-r--r-- 1 root root 31 Dec 8 12:14 modules.generic_string
-rw-r--r-- 1 root root 73 Dec 8 12:14 modules.ieee1394map
-rw-r--r-- 1 root root 1614 Dec 8 12:14 modules.isapnpmap
-rw-r--r-- 1 root root 29 Dec 8 12:14 modules.parportmap
-rw-r--r-- 1 root root 61251 Dec 8 12:14 modules.pcimap
-rw-r--r-- 1 root root 24 Dec 8 12:14 modules.pnpbiosmap
-rw-r--r-- 1 root root 121261 Dec 8 12:14 modules.usbmap
[jtsai@rhdual10]~: cat /proc/version
Linux version 2.4.21-27.ELsmp (bhcompile@bugs.build.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-47)) #1 SMP Wed Dec 1 21:59:02 EST 2004

jtsai 12-08-05 04:19 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
zander:

Yes as a workaround we are installing the kernel-source package on our machines.

Our goal however is mass deployment to all of our QC machines. These QC machines contain several versions of RHEL both 3.0 and 4.0. So what I am trying to do is to create a custom driver package containing all the necessary kernel versions that our software supports, without having to install the kernel-source packages, which is typically not installed by default on our customer's machines.

I went through this process a few months ago using 1.0-7174 and it worked great. But I can't revert to that version because there is a bug fix in 8174 that our software needs.

Thanks for your help.

netllama 12-08-05 04:24 PM

Re: 1.0-8174 isntaller cannot determine kernel version
 
jtsai,
I don't see anything wrong on your system. I assume that /usr/src/linux-2.4.21-27.EL exists on your system?

Can you try installing the driver one more time with only the '-s' switch? If it fails, please post the installer log again.

Thanks,
Lonni


All times are GMT -5. The time now is 08:49 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.