nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   question on TFT and linux driver. (http://www.nvnews.net/vbulletin/showthread.php?t=6139)

sabin 01-10-03 11:53 AM

question on TFT and linux driver.
Well I just got a Toshiba 2415 S205 notebook and linux runs great on it. I also insalled latest nvidia drivers for the "Nvidia gforce 4, 420 Go" thats in it. Previously I was running the vesa driver and things went well. I just wanted my extra 3d support if you know what i mean. Any way the problem:

After installing the nvidia drivers. Every thing went well and my opengl stuff works great but even though I have x configured correctly I't cuts out all my screen resolutions higher than 800x600. With the vesa driver I could go up to 1600x1200 in 32 bit.
Also I get a 2 cm empty black space on the right side of my display that never gets used ( in windows managers and fullscreen opengl ect. )
So the question comes has any one else had this problem? Should I write a report to nvidia. If you would like to see my XF86Config I have attached it. I had of course no problems with the vesa driver the display was on the ful screen ect.

Thanks for being there guys. Your advice is very helpful.


shel 01-10-03 12:39 PM

Same stuff...
I've got the same problem on Satellite 1410, tried various tricks but with no luck.
If you'll get any replies sentto your email, could you please forward these to shel_linux@email.com ?



shel 01-10-03 12:49 PM

oops, sorry that stuff was on the forum.

Try changing the options line to:

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2

for 4191 driver. That should do.



sabin 01-11-03 06:18 PM

Thanks I don't know how I missed it in the list.

You guys have been great.


thewag 01-29-03 10:50 PM

Same problem...NO LUCK on Satellite 1415
Ok, I've found plentty of possible fixes that don't work. This seems to be the closest to what I am experiancing with the same hardware. (Satellite 1415 and 1410 are same except for initial OS from factory.)

It seems that atleast on of the persons on this thread has had some luck. Would it be possible to post your XF86Config? Or atleast email me at thewag_at_wagners.homeip.net?


Wolfman [TWP] 01-30-03 06:33 AM

What is the external display that you are using??

According to the Toshiba Site, that notebook can only handle a resolution of 1024x768 maximum, and 1600x1200 using an external monitor.. :rolleyes:

thewag 01-30-03 08:38 AM

Only want 1024x768
TWP, I realize that it won't do 1600, but all I'm looking for is 1024x768. At the moment all I'm getting is 800 and a bar on the right of unused space. As for external monitor, I'm not using one.....yet :)

Wolfman [TWP] 01-30-03 07:33 PM

Has your XF86Config file been setup for 1024x768??

See the cut out section of my XF86Config file as an example below:-

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"

Using the above example, you should be able to use the CTRL-ALT-+/- (Numeric keys) to switch between these modes.

These have worked well for ALL the installs that I have done.. If it doesn't work, then there may be other issues causing some problems.

Possibly the Horizontal and Vertical information in that same file maybe not allowing you to go to 1024x768??

You will need to check the Toshiba Site to get these values that are required by X, to set the screen to the desired resolution.

Jeremy Bear 01-31-03 05:33 AM

Try modifying your XF86Config as follows: (works fine on my Tosh SatPro 6100 with same NV chip)

Make a backup of your XF86 Config (/etc/X11/XF86Config) then modify it as follows:

"Module" section:

1. Remove the line> Load "dri"
2. Remove the line> Load "GLcore"
3. Ensure you have the line> Load "glx"

"Monitor" section:

For a basic setup, all you need is:

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Toshiba 6100 LCD Display"
HorizSync 31.5 - 150
VertRefresh 50.0 - 100
Modeline "1024x768" 97.40 1024 1072 1192 1416 768 768 771 809
Option "ddc" "off"

"Device" section:

It's very important that the Driver line is changed from "nv" or "vesa" to "nvidia". Also, remember to check the amount of video RAM you have, and decide whether you want BackingStore on or off. (Must be off if you are using Win4Lin).

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce 4 420 Go"
VideoRam 32768
Option "BackingStore" "Off"

"Screen" section:

You can add more modes as required, but note that each must have a valid modeline in the "Monitor" section. The "Virtual" line disables the display panning that would otherwise occur by default, and forces the driver to display everything within the confines of the screen dimensions.

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
SubSection "Display"
Depth 24
Modes "1024x768"
Virtual 1024 768

Assuming all is well, you may notice a black vertical line at the right hand side of the screen. To get rid of this, add the following line to /etc/modules.conf :

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2

and re-boot.

Good luck!


All times are GMT -5. The time now is 09:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.