nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia-installer (1.0-8174) fails when compiling kernel interface (http://www.nvnews.net/vbulletin/showthread.php?t=61392)

corphicks 12-10-05 10:15 AM

nvidia-installer (1.0-8174) fails when compiling kernel interface
 
I'm using a minor distro called UHU-Linux. Sadly, this means, there's no precompiled kernel interface available for my kernel, so nvidia-installer tries to compile one, but then stops with an error:

Code:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Dec 10 16:43:09 2005

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall              : false
  driver info            : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files    : true
  no questions            : false
  silent                  : false
  no backup              : false
  kernel module only      : false
  sanity                  : false
  add this kernel        : false
  no runlevel check      : false
  no network              : false
  no ABI note            : false
  no RPMs                : false
  force tls              : (not specified)
  force compat32 tls      : (not specified)
  X install prefix        : /usr/X11R6
  OpenGL install prefix  : /usr
  compat32 install prefix : (not specified)
  installer install prefix: /usr
  utility install prefix  : /usr
  kernel name            : (not specified)
  kernel include path    : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path    : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list          : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
  ke the installer to attempt to download a kernel interface for your kernel f
  rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
  this means that the installer will need to compile a kernel interface for
  your kernel.
-> Performing CC test with CC="cc".
-> Kernel source path: '/lib/modules/2.6.9-19/source'
-> Kernel output path: '/lib/modules/2.6.9-19/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Cleaning kernel module build directory.
  executing: 'cd ./usr/src/nv; make clean'...
  rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
  agp.o os-interface.o os-registry.o nvidia.mod.o
  rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
  rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
  rm -f -f stprof stprof.o symtab.h
  rm -f -rf .tmp_versions
-> Building kernel module:
  executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.9-19/source
  SYSOUT=/lib/modules/2.6.9-19/build'...
 
  NVIDIA: calling KBUILD...
  make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.9-19/build KBUILD_VERBOSE=1 -C /li
  b/modules/2.6.9-19/source SUBDIRS=/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-
  pkg1/usr/src/nv modules
  make -C /lib/modules/2.6.9-19/build                \
  KBUILD_SRC=/usr/src/linux-2.6.9-19            KBUILD_VERBOSE=1        \
  KBUILD_CHECK= KBUILD_EXTMOD="/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/
  usr/src/nv"        \
          -f /usr/src/linux-2.6.9-19/Makefile modules
  mkdir -p /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/.tmp_vers
  ions
  make -f /usr/src/linux-2.6.9-19/scripts/Makefile.build obj=/tmp/selfgz3544/N
  VIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv
  echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz3544/NVI
  DIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nv_compiler.h
    cc -Wp,-MD,/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/.nv.o
  .d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/s
  rc/linux-2.6.9-19/include  -I/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/
  usr/src/nv -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fn
  o-common -O2 -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i586 -I/
  usr/src/linux-2.6.9-19/include/asm-i386/mach-default -Iinclude/asm-i386/mach
  -default  -I/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv -Wall
  -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -
  Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wsign-compare -Wno
  -cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -DN
  VRM -DDYNAMIC_SLI -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=
  8174 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SYSCTL_MAX_MAP_COUNT_PRESENT -DNV_REMAP_
  PAGE_RANGE_5_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_VMAP_4_PRESENT -DMOD
  ULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz3544/NVIDI
  A-Linux-x86-1.0-8174-pkg1/usr/src/nv/nv.o /tmp/selfgz3544/NVIDIA-Linux-x86-1
  .0-8174-pkg1/usr/src/nv/nv.c
  In file included from include/linux/list.h:7,
                    from include/linux/wait.h:23,
                    from include/asm/semaphore.h:41,
                    from include/linux/sched.h:18,
                    from include/linux/module.h:10,
                    from /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src
  /nv/nv-linux.h:47,
                    from /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src
  /nv/nv.c:14:
  include/linux/prefetch.h: In function `prefetch_range':
  include/linux/prefetch.h:62: warning: pointer of type `void *' used in arith
  metic
  In file included from include/linux/dmapool.h:14,
                    from include/linux/pci.h:823,
                    from /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src
  /nv/nv-linux.h:71,
                    from /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src
  /nv/nv.c:14:
  include/asm/io.h: In function `check_signature':
  include/asm/io.h:240: warning: wrong type argument to increment
  /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nv.c: In function
  `nv_alloc_pages':
  /tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nv.c:3211: interna
  l compiler error: Szegmentálási hiba
  Please submit a full bug report,
  with preprocessed source if appropriate.
  See <URL:http://gcc.gnu.org/bugs.html> for instructions.
  make[4]: *** [/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nv.o
  ] Error 1
  make[3]: *** [_module_/tmp/selfgz3544/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src
  /nv] Error 2
  make[2]: *** [modules] Error 2
  NVIDIA: left KBUILD.
  nvidia.ko failed to build!
  make[1]: *** [mdl] Error 1
  make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
      '/var/log/nvidia-installer.log' for details.  You may find suggestions
      on fixing installation problems in the README available on the Linux
      driver download page at www.nvidia.com.

I didn't find any information in the README about this. By the way "Szegmentálási hiba" (HU) means "Segmantation fault".

Any clues, anyone?

zander 12-10-05 10:29 AM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
This doesn't look like a NVIDIA bug, your compiler crashes trying to build the kernel interface files; this is either a problem with your compiler, the kernel source tree you're building against or a combination of the two.

gnutux 12-10-05 10:49 AM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
try to install gcc 3.4 or gcc 4.0 (do not install the cvs)

gnutux

Spyke 12-10-05 11:44 AM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
Bad ram or an over-overclocked system can bring out loads of gcc crashes.
I suggest running mprime -t if your gcc version is 3 or 4 releases.

clipseboy 12-18-05 11:56 AM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
1 Attachment(s)
hello people,

I got the same problem as like coprhicks,

i tried to install the new graphic drivers
Linux Display Driver - IA32 Version: 1.0-8174
by following steps

init 3
rmmod nvidia
modprobe agpgart - "without sucess - the agp module is used by via"
sh NVIDIA-Linux-x86-1.0-8174-pkg1.run -q

and first i get the Error Message
"no Precompiled kernel interface found-try to download?"
-> i said yes but
"no precompield kernel interface found on internet - try to compile?"
-> i said yes again but
"can' t compile kernel interface" make sure gcc is installed and its in your path"

the only difference is - i am using SUSE Linux 10.1

I attached my nvidia-installer.log

am i doing anything wrong - what is the problem in here?
you are appreciated for any help - thanks

clipse

netllama 12-18-05 12:09 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
You need to install the gcc RPM. Its typically a part of the 'development' group of packages during the OS installation.

Thanks,
Lonni

clipseboy 12-18-05 01:04 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
hey

thanks

i installed gcc and the kernel-sources now! and restarted the system
( i am a noob - i thought this were installed already because i didnt see it on the new installable packages site)

ok - but i get the following error message now

"The kernel header file
/lib/modules/2.6.13-15.7-default/build/include/linux/kernel.h
does not exist"

"The most likelyreason for this is that the kernel source path
/lib/modules/2.6.13-15.7-default/build
is incorrect"

"Pls make sure you installed kernel-sources rpm and it is properly configured"

"You can configure it with the command line --kernel -source -path"

i am using SUSE Linux 10.1

what can i do next?
i am sure we will manage that problem

netllama 12-18-05 01:41 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
Does SuSE-10.1 have a kernel-devel RPM? If so, please install it. If not, then please post the output from the following commands:
uname -a
cat /proc/version
ls -l /lib/modules/`uname -r`

Thanks,
Lonni

clipseboy 12-18-05 01:58 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
i am not sure if SUSE got that kernel-devel RPM
but i looked at Yast2 and there is nothing like that
i am loged in as root

here is the output of the commands

-> linux:~ # uname -a
Linux linux 2.6.13-15.7-default #1 Tue Nov 29 14:32:29 UTC 2005 i686 athlon i386 GNU/Linux

-> linux:~ # cat /proc/version
Linux version 2.6.13-15.7-default (geeko@buildhost) (gcc version 4.0.2 20050901 (prerelease) (SUSE Linux)) #1 Tue Nov 29 14:32:29 UTC 2005

-> linux:~ # ls -l /lib/modules/`uname -r`
total 1308
drwxr-xr-x 4 root root 512 Dec 14 01:47 .
drwxr-xr-x 5 root root 144 Dec 14 01:47 ..
lrwxrwxrwx 1 root root 43 Dec 14 01:47 build -> /usr/src/linux-2.6.13-15.7-obj/i386/default
drwxr-xr-x 2 root root 3560 Dec 14 01:47 extra
drwxr-xr-x 10 root root 240 Dec 14 01:47 kernel
-rw-r--r-- 1 root root 281843 Dec 14 01:47 modules.alias
-rw-r--r-- 1 root root 69 Dec 14 01:47 modules.ccwmap
-rw-r--r-- 1 root root 331086 Dec 14 01:47 modules.dep
-rw-r--r-- 1 root root 813 Dec 14 01:47 modules.ieee1394map
-rw-r--r-- 1 root root 627 Dec 14 01:47 modules.inputmap
-rw-r--r-- 1 root root 21487 Dec 14 01:47 modules.isapnpmap
-rw-r--r-- 1 root root 74 Dec 14 01:47 modules.ofmap
-rw-r--r-- 1 root root 226871 Dec 14 01:47 modules.pcimap
-rw-r--r-- 1 root root 967 Dec 14 01:47 modules.seriomap
-rw-r--r-- 1 root root 123527 Dec 14 01:47 modules.symbols
-rw-r--r-- 1 root root 317663 Dec 14 01:47 modules.usbmap
lrwxrwxrwx 1 root root 26 Dec 14 01:47 source -> /usr/src/linux-2.6.13-15.7
linux:~ #


clipse

netllama 12-18-05 02:51 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
I don't have a SuSE system in front of me to verify the correct behavior, however, it looks like you're pointing to two different kernel source paths inside of /lib/modules/`uname -r` :
build -> /usr/src/linux-2.6.13-15.7-obj/i386/default
source -> /usr/src/linux-2.6.13-15.7

Based on your error message, I'd suggest fixing the build symlink so that it points to /usr/src/linux-2.6.13-15.7/i386/default

If that doesn't fix things, then please post the nvidia installer log from /var/log.

Thanks,
Lonni

zander 12-18-05 03:26 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
@clipseboy: please install the kernel-source package and try the installation (please also see http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html). If you continue to have problems, please attach an updated nvidia-installer.log file.

clipseboy 12-18-05 04:08 PM

Re: nvidia-installer (1.0-8174) fails when compiling kernel interface
 
hi

@netlama
@zahnder

it works now
i got the new driver installed on my system

i dont know why i wasnt able to install it before!
i dont tried that to fix it with the symlink stuff - cause i dont know how

@ all

for other people who got the same problem

all i did was to look again in Yast2 and check if i marked "kernel-sources"
it was marked as ever before - so i decided to mark it as "update"

at the End Yast2 said i have to reboot to make changes effective
after succesfull restart i changed to "init3" and installed the new driver with sucess

thanks for the help
you are appreciated


clipse


All times are GMT -5. The time now is 08:38 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.