nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xorg freezes with fx5200 (http://www.nvnews.net/vbulletin/showthread.php?t=61459)

EcchiM 12-11-05 05:25 PM

Xorg freezes with fx5200
 
Hello,
I've a X-locks-but-mouse-can-be-moved problem. But I don't have any pci_badness-errogs in my syslog, so I'm not sure if it is the same problem.
I'm not sure, but I have the feeling that happens more often if I display bigger elements. For example an big website. If i only use a few terminals nothing happens, but surfing is really problematic. The nv driver works perfectly.
I had the same problem using Arch Linux with Xorg, so I tried debian sarge with Xorg from the unstable tree. But that didn't change anything.

I did a startx -- -logverbose 5 and sleep 5m; nvidia-bug-report.sh and could reproduce it (again..). So here my nvidia-bug-report.log:
http://myloo.de/~marcel/nvidia-bug-report.log

netllama 12-11-05 05:54 PM

Re: Xorg freezes with fx5200
 
I have a few questions:
0) Did this problem exist with 1.0-7676 as well?
1) What kind of motherboard are you using and which BIOS version?
2) Does this problem exist with color depth of 24 too?

Thanks,
Lonni

EcchiM 12-12-05 12:19 AM

Re: Xorg freezes with fx5200
 
Hi Lonni!

Quote:

Originally Posted by netllama
I have a few questions:
0) Did this problem exist with 1.0-7676 as well?

Yeah. I had a 3dProphet2GTS with the legacy driver and it were stable. Then i switched to the fx5200 with the 1.0-7676 and had this problem. I tried the 1.0-8174 as well, but it didn't solve the problem.

Quote:

Originally Posted by netllama
1) What kind of motherboard are you using and which BIOS version?

I've got an ECS K75SA and my bios is an Amibios v1.21.11.

Quote:

Originally Posted by netllama
2) Does this problem exist with color depth of 24 too?

It seems to be stable with 24bit (thanks!), but only as long as I don't start glx-things. Starting glxgears crashes Xorg usually after about 30 seconds.
Additionally it's a lot slower with 24bit, I only get 700fps (glxgears - 24bit), but with 16bit I've ~1300 fps. Or is that usual?

Thanks for your help!

Marcel

netllama 12-12-05 10:33 AM

Re: Xorg freezes with fx5200
 
I'm not able to find your K75SA motherboard on ECS's website. Can you point me to the URL for it?

Thanks,
Lonni

EcchiM 12-12-05 11:11 AM

Re: Xorg freezes with fx5200
 
Ah, Sorry, a Typo.
It's K7S5a: http://www.ecs.com.tw/ECSWeb/Downloa...uID=45&LanID=0

But unfortunately I discovered, that 24bit didn't work as well as I thought.
When I'm typing text in licq e.g. I can provoce a crash in less than a minute.
I logged in remotely and tried to find out something. Xorg eats all of my cpu and I could only kill it with -9.
Sometimes there's a line with 1px height through the text (when it crashes) and it doesn't draw the last character in that text right. When it is a 'n' it only draws about 50% of the character (up to down). XOrg doesn't respond, so I couldn't make a screenshot.

Should I try a new Bios version? They have two versions on the website i pointed above. But the bios patch with the higher version number is older. Should i try both of them or do you have something special in mind?

Thanks in advance,

Marcel

netllama 12-12-05 11:33 AM

Re: Xorg freezes with fx5200
 
I'd certainly suggest updating your BIOS. I would recommend applying the newest BIOS which is compatible with your motherboard.

Thanks,
Lonni

EcchiM 12-12-05 12:10 PM

Re: Xorg freezes with fx5200
 
I updated my Bios but the problem remains..
When I use windows the system is stable. So I think that's not a problem between my mainboard and my graphic card.

Thanks,
Marcel

netllama 12-12-05 12:33 PM

Re: Xorg freezes with fx5200
 
Can you try booting with the noapic and/or acpi=off kernel parameters and see if that makes any difference?

Thanks,
Lonni

EcchiM 12-12-05 12:46 PM

Re: Xorg freezes with fx5200
 
Nope, didn't solve the problem.
Would it help if I provide straces or a gdb-log of X?

netllama 12-12-05 01:02 PM

Re: Xorg freezes with fx5200
 
Have you tested with more than one window manager?

Can you try disabling AGP (NvAGP=0) and also experimenting with other values of NvAGP, and see if that has any impact?

Thanks,
Lonni

EcchiM 12-13-05 10:30 AM

Re: Xorg freezes with fx5200
 
Ahh! I think that was it.
I used apggart (because its faster than nvidia-agp on my machine). Now I tried the nvidia-internal-agp and it works. Thanks a lot for your time and effort!

nc-colin 12-14-05 12:50 AM

Re: Xorg freezes with fx5200
 
Please post exactly what you did to correct the problem.

I have been fighting the same issue for a while with all versions of the driver.

Thanks for your help!


All times are GMT -5. The time now is 11:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.