nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Cannot make Nvidia Driver for 2.4.19_18.8 (http://www.nvnews.net/vbulletin/showthread.php?t=6167)

3777 01-11-03 12:34 AM

Cannot make Nvidia Driver for 2.4.19_18.8
 
I have been using the Tar GZ method for a couple of kernel and driver upgrades now without a hitch, but after downloading the newest Redhat kernel....... when I attempt to make the driver for it, after typing "make" ......it says "make: ***No rule to make target '/lib/modules/2.4.18-18.8.0/build/include/linux/config.h' , needed by 'nv.o' Stop.

Anyone have any idea what this means? I currently have the 4191 drivers installed for red hat 2.4.18-18.8 and working great......had changed nv to nvidia......Is this why it can't find this file for nv.o driver? .....I dunno.... help?


P.S. If I can't use redhat 2.4.18-19.8 .......then is there a way for my to get rid of it since the other kernel is working fine....... ?

3777 01-12-03 06:56 PM

:confused:............anybody? ................ :(

bwkaz 01-12-03 09:46 PM

You're using 2.4.18-19.8, but the error message is talking about 2.4.18-18.8/build. This is a pretty good indication that you either mistyped something ( ;) ) or weren't booted into the new kernel when you compiled the driver. As long as the running kernel matches the kernel you'll use to run the driver, and you have the build symlink in /lib/modules/<version>, it should work.

You do have kernel-source-2.4.18-19.8 installed, right? Did you configure it (should be just like all other kernels)?

3777 01-12-03 09:55 PM

Quote:

Originally posted by bwkaz
You're using 2.4.18-19.8, but the error message is talking about 2.4.18-18.8/build. This is a pretty good indication that you either mistyped something ( ;) ) or weren't booted into the new kernel when you compiled the driver. As long as the running kernel matches the kernel you'll use to run the driver, and you have the build symlink in /lib/modules/<version>, it should work.

You do have kernel-source-2.4.18-19.8 installed, right? Did you configure it (should be just like all other kernels)?

I had the 2.4.18-18 kernel and 4191 drivers installed and running fine, then I updated the Redhat Kernel to 2.4.18-19 .......but it won't let me build a 4191 driver from the tar.gz source now. I get the error message I mentioned in the first post........ ? I was definitely booted into the new kernel .... (because Xserve doesn't start in the new one..... ) ........and I definitely didn't mistype anything......

junkieclown 01-12-03 10:04 PM

you need to upgrade kernel-source rpm along with kernel rpm if you haven't, then 'make clean && make install' in your Nvidia_kernel source directory.

3777 01-12-03 10:52 PM

Quote:

Originally posted by junkieclown
you need to upgrade kernel-source rpm along with kernel rpm if you haven't, then 'make clean && make install' in your Nvidia_kernel source directory.
That was it!!! I went to the kernel directory, typed make clean, then everything installed fine. Thanks, I had been stumped for a week!!!:D


All times are GMT -5. The time now is 12:45 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.