nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   BUG: Interleaved black lines when playing video at full screen (http://www.nvnews.net/vbulletin/showthread.php?t=6177)

puterguy 01-11-03 05:11 PM

BUG: Interleaved black lines when playing video at full screen
suspect that the following problem is an nVidia driver problem and would like to get other people's inputs here.

I have been using mplayer to play back avi clips and dvds.

Mplayer displays videos perfectly sharp when playing AVI files or DVDs at normal size.

When I try to play at double-screen size or full-screen size
(1280x1024), the picture doesn't seem to scale properly. Looking
closely at the screen, it seems that instead of properly scaling the
picture, 1 pixel thin horizontal black lines are interleaved between
every few original image lines in a regular pattern. It looks
somewhat like this (where even between the closest-spaced black lines, there are perhap 5 or 6 normal image lines):





The effect is worse at full-screen than at double-screen. The result
is that the picture looks very jagged and blurry and thus is almost
impossible to view.

I have tried playing with some of the options on the gmplayer menu
e.g. turning on/off interleaving, adjusting cache size, turning on/off
direct rendering, adjusting postprocessing...

I am running RH8.0/Linux2.4.20 on a P4 2.53GHz with 1Gig PC2700 DRAM
and a Leadtek Ultra A250 GF4 (nvidia 4600) graphics card running the
latest nvidia drivers (NVIDIA_GLX-1.0-4191.i386.rpm

I am using the following packages downloaded from psyche.freshrpms.net

I suspect that this is more of a driver than an mplayer problem.
Any thoughts on what might be going on here???

puterguy 01-16-03 11:10 PM

Anybody out there have the same problem?

Wolfman [TWP] 01-17-03 06:12 AM

Nope, I haven't seen that problem. I'm using RH8.0 with their latest kernel, the Nvidia 4191 drivers. I run Xine, and it displays DVD's FULL screen, crystal .. I'm running pretty much the same packages as you, but using Xine. That's goes the same for AVI's, MPEG's and well as VCD's, all show up great at full screen.

I forgot to mention, and at the same 1280x1024 resolution..

I would check your XF86Config file to see that there isn't something that shouldn't be there, or that there maybe something missing...

puterguy 01-17-03 07:18 AM

Interesting, because I get the same problem in both ogle and mplayer (I can't seem to get xine to work at all but I'm sure it would have the same problem :( )

One other interesting element of my problem is that when I enlarge the window manually, the picture scales properly until the picture gets to be about 2/3 of the full-screen and then it suddenly starts getting the stray lines. I am really stumped by this problem.

My XF86Config file is basically unmodified. Here is my device stanza.

Section "Device"
# no known options
# Driver "vesa"
Driver "nvidia"
Identifier "NVIDIA GeForce 4 (generic)"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
# Option "renderAccel" "true"

Any suggestions?

bwkaz 01-17-03 07:58 AM

I don't have a DVD drive, but my mplayer plays AVIs just fine in both fullscreen and 2x mode. Then again, I'm still using 3123, too...

Which input codec library does your version of mplayer use for AVI files? When I installed it (from CVS checkout from their servers, BTW), there was an option to get a better version of libavcodec, that (according to mplayer docs) supported the vast majority of its formats a good deal better than anything else -- but that libavcodec had a separate CVS repository somewhere else. So if the people that built your version of mplayer didn't use that libavcodec, it's possible that that could cause it. Maybe.

Of course, if you're seeing it in Ogle too, then maybe not. Does changing to 3123 help?

Wolfman [TWP] 01-17-03 08:06 AM

My XF86Config file is not that much different.

Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
Option "NvAGP" "1"
Option "DigitalVibrance" "2"
Option "CursorShadow" "1"
Option "RenderAccel" "true"

I can't understand why Xine doesn't work for you. As I've installed it on three (3) different systems without a problem.. All files from psyche.freshrpms.net too. :confused:

puterguy 01-17-03 09:19 AM


Interesting. I suspect that everything worked ok in 3123 since I recall watching at least one DVD at fullscreen and I am sure I would have noticed the degradation.

I tried downgrading back to 3123, but couldn't manage to get X to start up right.

I don't think it is a codec or player issue since the problem occurred both with DVDs and with avifiles and both with mplayer and with ogle.

Also, I assume it is not a direct hardware problem, since DVDs play just fine under M$ XP.

This leaves me with the suspicion that it is either a driver or a configuration problem. Since my XF86Config is pretty vanilla and since I have a standard RH8.0 X11 installation, I suspect it is a driver issue with scaling.

I guess I should try one more time to downgrade back to 3123 to test the hypothesis.

puterguy 01-17-03 09:22 AM

I am not sure what is going on with Xine either!

I grabbed all the relevant rpms off of psyche.freshrpms.net too.
I will post a more detailed description of the error messages over the weekend when I get back to my machine.

Demian 01-24-03 01:37 AM

going crazy
I have the same problem and it is driving me insane. I am running an inspiron8k with geforce2go 32mb. I am running debian sid. This problem is just as you explained. I fixed the problem by downgrading to 3123 and compiling from source, however the lastest update of deian's xsever-xf86 package recreated the problem and Im pissed off! I have found one solution. Start a different movie in mplayer and go to fullscreen and you should have the black lines. Now open the video you want and it should work in fullscreen no prob. This doesnt make since to me as the problem doesnt seem to be repeatable. If you cycle between fullscreen and normal about 15 it will eventually work - go figure...
I hope someone has a better solution since with the latest xserver upgrade 3123 is no longer working.

Demian 01-24-03 02:48 AM

I have downgraded my xserver-common packages and I still have the problem. Lets try to narrow it down. I am 99% sure its an xv scaler problem, since i can view videos in vesa and aalib with no lines. I had the problem fixed for a while when I downgraded to 3123, but as I said before when I upgraded xserver-common the problem came back.
1. The upgrade changed my XF86Config-4, so there may be some obscure setting there that fixes it.
2. I had also recompiled my kernel, because my old kernel was compiled with an older gcc, now im using 3.2.2. When fullscreen was working without lines I was using linux 2.4.20 compiled with i think gcc 2.9.6 and the 3123 drivers which worked were also compiled with that version. So it may be a build problem?
3. problem with something in xv scaler in the xserver package that wasnt erased when i downgraded?

Thats all i can think of at the moment. Again, the weird weird weird thing is that if i open up 2 movies the scaler will work on the 2nd and it will scale fine with no lines. As long as xv is already running it seems the scaler works, but not on the first try :rolleyes:

I have also tried 4 other sets of older nvidia drivers and all of them have the scaling problem. The problem appears in ogle, mplayer, xine, aviplay etc. so its definately a driver and/or xv scaler problem.

Demian 01-24-03 03:50 AM

solved - sorta
Well after about 5 hours, I tried adding
Option "NvAgp" "0"
to my device section and....NO MORE LINES in fullscreen.
However, i don't have agp now - is that a problem? I don't play games right now so do I really need it?

Demian 01-24-03 04:04 AM

last update
The problem is with AgpArt being compiled into the kernel. I realized that when I didn't have a problem with lines was when I had agpart compiled as a module. So you can recompile and make agpart a module or set "NvAgp" to "1" which uses the nvidia driver agp rather than the kernel. That worked for me, so I have agp and no lines. Let me know if this helps - I'm very happy to have finally fixed this annoying problem that has been bothering me for months!

All times are GMT -5. The time now is 01:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.