nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Legacy Graphics Cards (http://www.nvnews.net/vbulletin/forumdisplay.php?f=37)
-   -   TNT 2 broken under Ubuntu (http://www.nvnews.net/vbulletin/showthread.php?t=61818)

grzebo 12-18-05 04:54 PM

TNT 2 broken under Ubuntu
 
Hello,
I spent past 20 hours searching for a way to use Nvidia driver version 7174 under Ubuntu.

My card is TNT 2, my system is Ubuntu Breezy Badger with 2.6.12-9-k7 kernel.

I did pretty much everything that I could find on Google, and the card still does not work.

What happens is: when I turn on kdm or run startx the screen goes blank, blinks once (as if from changing resolution) and then the whole system hangs.

I installed the driver from the legacy package, provided correct kernel headers, used correct version of the GCC. The nodes in /dev/nvidia[0-7] and /dev/nvidiactl are being created correctly (when I create them manually, it makes no difference). When I do "modprobe nvidia" it loads cleanly, I do not have any nvidia framebuffer modules loaded.

I use an xorg.conf that worked with my previous sytem (but with 2.4 kernel), so that's not the problem either.

I did about a hundred different things that were supposed to help, according to posts from different forums (uninstalled udev, commented out glx in xorg.conf, and many more I don't remember), and have lost all hope of making this work.

Does anyone have any ideas?

Thank you in advance for your help.

Grzegorz Borek



The relevant logs are:
=================================================
/var/log/Xorg.0.log:

(...)
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xCA000000
(--) NVIDIA(0): MMIO registers at 0xCC000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

====================================
/var/log/messages:

Dec 18 16:17:25 localhost kernel: [4294752.561000] nvidia: module license 'NVIDIA' taints kernel.
Dec 18 16:17:25 localhost kernel: [4294752.595000] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
Dec 18 16:17:25 localhost kernel: [4294752.595000] ACPI: PCI Interrupt 0000:01:00.0[A] -> Link[LNKA] -> GSI 5 (level, low) -> IRQ 5
Dec 18 16:17:25 localhost kernel: [4294752.596000] NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7174 Tue Mar 22 06:44:39 PST 2005

[and that's when the system stopped]

a12ctic 12-18-05 04:57 PM

Re: TNT 2 broken under Ubuntu
 
you need legacy drivers...

sudo apt-get install nvidia-glx-legacy

oh wopsy uhh im not sure..

grzebo 12-18-05 05:04 PM

Re: TNT 2 broken under Ubuntu
 
These are legacy drivers. The latest and the only ones that work nicely with kernel 2.6. I don't think that they are the problem - unlike all the other drivers (yup, I tried about 10 different versions, just in case), they compile nicely and the module loads without a glitch.

In one forum somewhere I found an advice that installing these from Nvidias package is a better way to get the card to work, than using Ubuntu's packages.

Grzegorz Borek

a12ctic 12-18-05 05:05 PM

Re: TNT 2 broken under Ubuntu
 
why dont you just use the defaults? what do you really need the drivers for? the nv driver should be fine... Your not expecting good 3d?

grzebo 12-18-05 05:14 PM

Re: TNT 2 broken under Ubuntu
 
No, I'm not expecting to play 3d games on that. I would however like to watch some movies, and nvidia drivers make scaling much easier on the cpu.

Grzegorz Borek

adri00 01-20-06 02:44 AM

Re: TNT 2 broken under Ubuntu
 
GRZEBO, I had the problem you had with my TNT card and the problem is cased by the default color depth and resolution settings in xorg.conf. The card does not support the default resolution-colordepth-refresh rate combination.

I set my default settings in the screen section

DefaultDepth 24

to

DefaultDepth 16

and it all went fine at 1920x1440 on first reboot.

I will now try and play with the modes in the 24 depth subsection and try to see if I can get a 24bit depth at a lower resolution to work.

I will try and let you know about the results. Let me know if this helps

Good luck

adri00 01-20-06 03:26 AM

Re: TNT 2 broken under Ubuntu
 
Yup it works if you also change the modes by removing the unsupported display resolutions..

By the way I did not make any changes to any drivers for the card they are the ones in the release cd...


All times are GMT -5. The time now is 12:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.