nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Dual-head and separated screens (:0.0/:0.1) (http://www.nvnews.net/vbulletin/showthread.php?t=61869)

LubosD 12-19-05 05:23 PM

Dual-head and separated screens (:0.0/:0.1)
 
1 Attachment(s)
Hello,

I am trying to have a separate X session on each monitor (LCD and CRT).

I have found a lot of example xorg.confs but I can't make it work...mabye I just missed something.
It always gives me "More than one matching Device section found: device2" - both :0.0 and :0.1 start on monitor 0 (LCD).

Can you please tell me what am I doing wrong? My current xorg.conf is attached.

Thanks,
Lubos

hermier 12-19-05 05:30 PM

Re: Dual-head and separated screens (:0.0/:0.1)
 
Try to put the connected monitor to "CRT-0" and "DFP-0".
Seems to be the only *error* I see.

mo_x 12-19-05 06:01 PM

Re: Dual-head and separated screens (:0.0/:0.1)
 
The BusID is missing from the device section, see the nvidia README.
Try also removing the ConnectedMonitor option.

LubosD 12-20-05 01:15 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
Quote:

Originally Posted by mo_x
The BusID is missing from the device section, see the nvidia README.
Try also removing the ConnectedMonitor option.

I think that BusID is not necessary when there is only one card.

LubosD 12-20-05 01:20 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
I have tried DFP-0 and CRT-0 - did not help.
I have removed ConnectedMonitor Options - now it just always starts on the CRT. It still complains about more matching Device sections. :(

When I add BusID: The requested device configuration is not supported in the hardware.

fm2503 12-20-05 04:53 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
Try:
Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1" 0 0
Screen "screen2" RightOf "screen1"
EndSection

(Note the added 0 0)
Also try adding
Section "ServerFlags"
Option "Xinerama" "false"
EndSection

mo_x 12-20-05 05:42 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
Maybe you used the wrong BusID. Can you create a nvidia-bug-report.log (run the nvidia-bug-report.sh script as root) and attach it.

LubosD 12-20-05 09:01 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
1 Attachment(s)
BusID should be correct, it complains when I use a different one...

Current errors:
(EE) NVIDIA(1): The requested configuration of display devices is not
(EE) NVIDIA(1): supported in the hardware.
(EE) NVIDIA(1): Failed to unmap registers.
(EE) NVIDIA(1): Failed to unmap registers.
(EE) NVIDIA(1): Failed to free registers.

and it always starts on screen 0 (LCD).

Attaching my current xorg.conf...
Maybe someone from nVidia could help?

Imperito 12-20-05 09:13 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
I get that same error in 8174, I have to use 7676, where it works.

mo_x 12-20-05 09:24 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
I think the CRT will be used as you primary display so try to exchange the CRT-0 and DFP-0 options. The contents of /var/log/Xorg.0.log which is also include in the nvidia log would also be very useful.

LubosD 12-20-05 09:29 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
Quote:

Originally Posted by mo_x
I think the CRT will be used as you primary display so try to exchange the CRT-0 and DFP-0 options.

When I swap CRT-0 and DFP-0 it stops working completely (both monitors are blank).

There are no more errors in the Xorg.0.1.log than "The requested configuration...". There is just some warning:
(WW) NVIDIA(0): Failure reading FlatPanel flags for DFP-0.

mo_x 12-20-05 10:02 AM

Re: Dual-head and separated screens (:0.0/:0.1)
 
I am not sure, maybe you need a modeline or something else. Without the log files it's hard to tell.


All times are GMT -5. The time now is 10:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.