nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem running NFORCE-Linux-x86_64-1.0-0310-pkg1.run on debian 2.6.8-11-amd64-k8 (http://www.nvnews.net/vbulletin/showthread.php?t=62177)

rustonm 12-25-05 03:04 PM

Problem running NFORCE-Linux-x86_64-1.0-0310-pkg1.run on debian 2.6.8-11-amd64-k8
 
(xmassign)
I'm fairly new to linux and am having a few problems installing the nvidia network and sound drivers on my debian system.

I've installed the appropriate kernel source package /usr/src/kernel-source-2.6.8 and executed NFORCE-Linux-x86_64-1.0-0310-pkg1.run
The script completes the kernel compilation but then fails with the errors below.

I'm hoping someone else has experienced and overcome such a problem becauase at the moment I'm a little stumped.
Any help or suggestions would be greatly appreciated.
Thanks.

----------------------------------------------

The sound driver installation log ends with this:
-> done.
-> Kernel module compilation complete.
-> Testing kernel module:
-> Copying test module ./nvsound/main/nvsound.ko to
/lib/modules/2.6.8-11-amd64-k8/kernel/sound/oss/nvsound.ko
ERROR: Unable to load the kernel module 'nvsound.ko'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: FATAL: Error inserting nvsound
(/lib/modules/2.6.8-11-amd64-k8/kernel/sound/oss/nvsound.ko): Invalid module
format
-> Testing completed.
ERROR: Installation of the audio driver has failed. Please see the file
'/var/log/nvidia-nforce-installer.log' for details. You may find
suggestions on fixing installation problems in the README available on
the Linux driver download page at www.nvidia.com.


And the network driver this:
-> done.
-> Kernel module compilation complete.
-> Testing kernel module:
-> Copying test module ./nvsound/main/nvsound.ko to
/lib/modules/2.6.8-11-amd64-k8/kernel/sound/oss/nvsound.ko
ERROR: Unable to load the kernel module 'nvsound.ko'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: FATAL: Error inserting nvsound
(/lib/modules/2.6.8-11-amd64-k8/kernel/sound/oss/nvsound.ko): Invalid module
format
-> Testing completed.
ERROR: Installation of the audio driver has failed. Please see the file
'/var/log/nvidia-nforce-installer.log' for details. You may find
suggestions on fixing installation problems in the README available on
the Linux driver download page at www.nvidia.com.

plumnilly 12-25-05 07:35 PM

Re: Problem running NFORCE-Linux-x86_64-1.0-0310-pkg1.run on debian 2.6.8-11-amd64-k8
 
Hate to be "Me Too" but i'm getting the same errors on Mandrake 10.1, another difference is I'm trying to install the 32 bit packages. I get a very similar message when trying to install the video drivers. Nothing seems to work. In all my failures, I got the info that there was a "kernel interface" source on nvidia.com for download. If it's there, it's not where I can find it. Their search also comes up empty.

Any help would be greatly appreciated, it's been 20+ years since I did unix, and I am VERY new to linux.

Bob Jackson

walrus 12-26-05 03:27 AM

Re: Problem running NFORCE-Linux-x86_64-1.0-0310-pkg1.run on debian 2.6.8-11-amd64-k8
 
It does not work for me too.
But in fact, you don't need it.
It depends of your mobo.
I have an Asus P5ND2-Sli Deluxe (nF4), and devices are naturally recognized by kernel :
- LAN -> forcedeth
- sound -> AC97

HTH

rustonm 12-28-05 05:03 PM

Re: Problem running NFORCE-Linux-x86_64-1.0-0310-pkg1.run on debian 2.6.8-11-amd64-k8
 
(xmasmile)
I've found the problem, in my case anyway. The cause was a kernel version mismatch. I was running kernel version 2.6.8 and compiling against kernel source version 2.6.8 but on closer inspection my running kernel was actually 2.6.8_11 and my sources were for 2.6.8_16.
The solution was to compile a new kernel from the 2.6.8_16 sources without the drivers, install and boot to that kernel and then run the NFORCE-Linux-x86_64-1.0-0310-pkg1.run script.


All times are GMT -5. The time now is 11:59 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.