nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xorg 6.9 +8178 (http://www.nvnews.net/vbulletin/showthread.php?t=62327)

Bratag 12-28-05 10:21 AM

Xorg 6.9 +8178
 
For those who care I compiled the new release of xorg last night and it seems to work very well with 8178. Composite, render accel all stable. Only wierdness is that my windowmanger now takes longer to appear but that may be a side effect of the xorg - not nividia.

Nickolay Kolchi 12-28-05 11:03 PM

Re: Xorg 6.9 +8178
 
I have different experience. With composite extension under latest drivers (8178) several problems occure:
- XV still don't work. Video flicks, glitches and other nasty things.
- GL applications freeze server. (they work just OK without composite)
- Macromedia Flash don't work with composite (this have no relation to nvidia of course)

Nothing changed from Xorg 6.8 release.

So, X7.0 release is just a vaporware. They switched from Imake to Autoconf building system, introduced a "new rendering technology" XAA (side note: it is supported only on some exotic hardware) and have done nothing else.

We still have various problems with Composite. We still don't have working Xgl and so on. Great work!

Bratag 12-28-05 11:42 PM

Re: Xorg 6.9 +8178
 
Quote:

Originally Posted by Nickolay Kolchi
I have different experience. With composite extension under latest drivers (8178) several problems occure:
- XV still don't work. Video flicks, glitches and other nasty things.
- GL applications freeze server. (they work just OK without composite)
- Macromedia Flash don't work with composite (this have no relation to nvidia of course)

Nothing changed from Xorg 6.8 release.

So, X7.0 release is just a vaporware. They switched from Imake to Autoconf building system, introduced a "new rendering technology" XAA (side note: it is supported only on some exotic hardware) and have done nothing else.

We still have various problems with Composite. We still don't have working Xgl and so on. Great work!

No you still have issues - some people do not.

fabs0028 12-29-05 03:42 PM

Re: Xorg 6.9 +8178
 
Quote:

Originally Posted by Nickolay Kolchi
I have different experience. With composite extension under latest drivers (8178) several problems occure:
- XV still don't work. Video flicks, glitches and other nasty things.
- GL applications freeze server. (they work just OK without composite)
- Macromedia Flash don't work with composite (this have no relation to nvidia of course)

Nothing changed from Xorg 6.8 release.

So, X7.0 release is just a vaporware. They switched from Imake to Autoconf building system, introduced a "new rendering technology" XAA (side note: it is supported only on some exotic hardware) and have done nothing else.

We still have various problems with Composite. We still don't have working Xgl and so on. Great work!

Hello,
to answer to your complains :
- first of course xv still doesn't work and it will not as long as it doesn't change because it doesn't care of of the composite manager, it prints it output directly to the screen so it bypasses the composite manager and this is the source of the problem. If you uses Xshm instead it works like a charm and i that's it.

- Pretty much the same lack of communication between glx and composite that can explain the crashes even if it doesn't occur to everyone.

- For flash i can't answer.

Concerning xorg7, i would say that yes maybe you didn't saw a lot of changes but well i guess we aren't concerned but hey you think that changing the build lsystem is an easy task whereas it took a long time.
Even if there were not a lot of changes in this release, now all parts of the x server are splitted and so you can update each one separately and build same separately as well so it should be easier to update some pieces and the changes you want will arrive.
Concerning EXA, i think it is a good idea and it will improve speed on some point. I also read about xcb which is a future asynchronous replacement of the xlib which is the slow part of the X server.

See you

Fabien

Spyke 12-29-05 03:48 PM

Re: Xorg 6.9 +8178
 
the xvideo overlay is obsolete anyways.

fabs0028 12-29-05 04:35 PM

Re: Xorg 6.9 +8178
 
I can easily understand why :)
What is meant to be the default now? Xshm? whatelse ?
thanx for the answer :)


All times are GMT -5. The time now is 01:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.