nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Screen(s) found, but none have a usable configuration. (http://www.nvnews.net/vbulletin/showthread.php?t=62437)

Stella Artois 12-30-05 01:15 PM

Screen(s) found, but none have a usable configuration.
 
1 Attachment(s)
Hi,
I'm trying to use the nvidia driver for my Geforce 6700XL card, but I get the folowing error:
...
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xF4000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.
...

I can get X working using the vesa driver, but of course without all the nice features built in the card ...

the verbose errorlog is attached.

Any suggestions ?

Cheers

whig 12-30-05 03:05 PM

Re: Screen(s) found, but none have a usable configuration.
 
You are using gentoo which does not use the nvidia installer. emerge nvidia-kernel then nvidia-glx, and see if you can modprobe the kernel module. Get that far then startx. There are nvidia docs on the gentoo site.

Stella Artois 12-30-05 06:31 PM

Re: Screen(s) found, but none have a usable configuration.
 
Yes indeed, I used the http://www.gentoo.org/doc/en/nvidia-guide.xml to emerge nvidia-kernel then nvidia-glx.
This results in the state I am now ...
I am hoping there is a problem in my xorg.conf or some other configuration. Otherwise I may ber stuck with rare hardware ... I cannot find any information about the GeForce 6700 XL card.

whig 12-30-05 07:06 PM

Re: Screen(s) found, but none have a usable configuration.
 
Does the nvidia kernel module load? lsmod will tell you, and check with dmesg. You have a new card indeed, I wonder how supported it is.

Stella Artois 12-30-05 11:56 PM

Re: Screen(s) found, but none have a usable configuration.
 
Yes, the nvidia module is loaded.
In dmesg I see that the nvidia card is recognised, but with an unknown chipset...


All times are GMT -5. The time now is 02:55 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.