nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Installing twice works!! (http://www.nvnews.net/vbulletin/showthread.php?t=62509)

Orville 12-31-05 09:37 PM

Installing twice works!!
I compiled a new kernel ( and then ran "sh NVIDIA-Linux-x86-1.0-8178-pkg1.run" as instructed, but I got the popular black screen when starting Xorg.

After looking around these forums, I realised that my /usr/lib/tls directory was created but empty, and it is supposed to have "libnvidia-tls.so.1.0.8178" and "libnvidia-tls.so.1" in it. Someone had suggested creating this directory manually and reinstalling. But since it was already there, I tried a second install. It worked!

It seems that the first install creates the /usr/lib/tls directory, but fails to write to it. The second install manages to finish writing the files. NVidia should really fix this flaw in the script, but for now just trying running the install script again if you are having problems.

ddd999 01-01-06 08:21 AM

Re: Installing twice works!!
I try according to your advice,but fail

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation CVS repository.
See http://wiki.x.org/wiki/CvsPage for CVS access instructions.

X Window System Version (7.0.0 RC 2)
Release Date: 09 November 2005
X Protocol Version 11, Revision 0, Release
Build Operating System:Linux 2.6.9-22.ELsmp i686Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.14-1.1696_FC5 #1 Sat Nov 19 19:02:13 EST 2005 i686
Build Date: 17 November 2005
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/dev/null", Time: Sun Jan 1 22:16:16 2006
(++) Using config file: "/tmp/tmp1k0b8Gxorg.config"
(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

netllama 01-01-06 10:17 AM

Re: Installing twice works!!
Which distribution are you running? Please post your installer log after the initial failure occurs.

You're experiencing a completely different and unrelated problem. You need to use the --x-module-path installation option to specify the location of your X server's module path.


Orville 01-02-06 01:27 AM

Re: Installing twice works!!
1 Attachment(s)
Sorry Netllama,

I didn't keep the old installer log. As I recall, it had the same last line as the current log that indicated, "Your X configuration file has been successfully updated. Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86 (version: 1.0-8178) is now complete." I distinctly remember this message appearing after running the install script, too. It was a surprise to get the black screen upon reboot.

The new log correctly indicates that the tls items were not correctly installed the first time:
-> Validating previous installation:
-> Unable to access previously installed file
'/usr/lib/tls/libnvidia-tls.so.1.0.8178' (No such file or directory).
-> Unable to access previously installed symlink
'/usr/lib/tls/libnvidia-tls.so.1' (No such file or directory).
-> done.

My distribution is Debian (unstable). I updated the packages right before compiling a new kernel (, to ensure that there wouldn't be a compiler mismatch when I ran the nvidia installer. I already new there wouldn't be a precompiled driver to match from previous attempts to run the installer. There are some unofficial nvidia driver packages on the web compiled to match debian kernels, but I decided against trying them out in favour of getting the latest kernel. I also switched to Xorg a while ago.

netllama 01-03-06 10:25 AM

Re: Installing twice works!!
I have a few more questions:
0) Which nvidia driver version did you have installed before you experienced this problem? Or was this the first time you had installed the nvidia driver?
1) Does this problem reproduce every time you install a different nvidia driver version? In other words, if you try to install 1.0-8174, does the problem return?
2) If you install the driver with the -s switch does it still reproduce?
3) Just to confirm, you're installing the driver as root, and not with sudo or any other non-root alternative?


All times are GMT -5. The time now is 04:11 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.