nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [problem] segmentation fault (http://www.nvnews.net/vbulletin/showthread.php?t=62571)

arnam 01-02-06 10:45 AM

[problem] segmentation fault
 
Hi!

I have a problem under new nv drivers: when I want to start any application whitch is using libGl.so.1 (mplayer, quake4, doom4, glxgears etc.) I have a segmentation fault. The problem exists only when I'm logged in as a normal users, when I'm logged in as a root everything is working properly.

I have proper rights to libraries and glibc complied with nptl support. When I'm trying to use $LD_PRELOAD the same problem appears.

Please help, and sorry for my bad english.

My specs:

AMD BARTON 2,6 GHz
ABIT NF7-S
512 MB RAM
GIGABYTE GF 6600

GENTOO LINUX
KERNEL linux-2.6.13-gentoo-r3
GLIBC 2.3.5-r2
GCC 3.4.4-r1
XORG-X11 6.8.2-r6
NVIDIA DRIVERS 1.0.8178

netllama 01-02-06 03:42 PM

Re: [problem] segmentation fault
 
I'd guess that the permissions/ownership of /dev/nvidia0 are restricted (incorrectly) to only root.

-Lonni

arnam 01-02-06 05:20 PM

Re: [problem] segmentation fault
 
Quote:

Originally Posted by netllama
I'd guess that the permissions/ownership of /dev/nvidia0 are restricted (incorrectly) to only root.

-Lonni

ls -l /dev/nvidia*
crw-rw-rw- 1 root root 195, 0 Jan 2 23:36 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Jan 2 23:36 /dev/nvidiactl

netllama 01-02-06 05:36 PM

Re: [problem] segmentation fault
 
Please post a bug report.

Thanks,
Lonni


All times are GMT -5. The time now is 10:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.