nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   can't install the driver for GeForce4 440 (http://www.nvnews.net/vbulletin/showthread.php?t=6291)

songhuang 01-15-03 01:03 AM

can't install the driver for GeForce4 440
 
My video card is GeForce4 440,
I run NVchooser.sh,it said
Please download and install the following files:
NVIDIA_kernel-1.0-2960.src.rpm
NVIDIA_GLX-1.0-2960.i386.rpm

I downloaded the needed files and rebuild them,then
install, the result is this:
[root@control7 i386]# rpm -ivh NVIDIA_kernel-1.0-2960.i386.rpm
Preparing... ########################################### [100%]
1:NVIDIA_kernel ########################################### [100%]
depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/drivers/video/NVdriver
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: The module you are trying to load (/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver) is compiled with a gcc
version 2 compiler, while the kernel you are running is compiled with
a gcc version 3 compiler. This is known to not work.
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: insmod /lib/modules/2.4.18-14/kernel/drivers/video/NVdriver failed
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: insmod NVdriver failed

NVdriver installed successfully


WHY????
I run 'cat /proc/version',it said
[root@control7 i386]# cat /proc/version
Linux version 2.4.18-14 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002

I run 'gcc -v',it said
[root@control7 i386]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --host=i386-redhat-linux --with-system-zlib --enable-__cxa_atexit
Thread model: posix
gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)

The version of gcc is both 3.2!!!
Can you help me? I have been bored, I try again and again, but it failed again and again.
Oh,my God!

:confused:

bwkaz 01-15-03 08:21 AM

What does cc -v say? The same thing? What does echo $CC say?

The other thing is, you're using an old version of NVchooser.sh. This script is changed on every driver release -- you have to use the one that you download from the same page as the driver you're going to install.

That said, you probably want to get the NVchooser from either the 3123 download page or the 4191 download page, and run it. You may not even need to install from source.

songhuang 01-15-03 09:27 PM

thand you for your reply,according to your recommendation, I do the following things:
[root@control7 root]# cc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --host=i386-redhat-linux --with-system-zlib --enable-__cxa_atexit
Thread model: posix
gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)

And the value of CC is null !

After I upgraded the kernel form 2.4.18-14 to 2.4.18-18.8.0 and download the new NVchooser.sh and run it, it was successful.
:)

But I can't have the 3D function. I'll try it, thank you sincerely.


All times are GMT -5. The time now is 02:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.