nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Driver 5336 and Mandrake 10.1 - X does not run after boot... :( (http://www.nvnews.net/vbulletin/showthread.php?t=62959)

Patator 01-07-06 10:14 AM

Driver 5336 and Mandrake 10.1 - X does not run after boot... :(
 
1 Attachment(s)
Hello, after several attempts with 6629 and other distro, I finally found a combination that will work, or almost... :)


I have compiled driver 5336 successfully.
I have install modules successfully
I have started X succesfully
I rebooted and X would not start again. nvidia and agppart are both loaded. the alias char-major-195* nvidia in /etc/modprobe.conf is there, so why doesn't it work ?

Currently, in order to have it work, I do a re-install silently of the drivber at each boot, please help, this is really a hard way /:

Dr. Tyrell 01-07-06 01:09 PM

Re: Driver 5336 and Mandrake 10.1 - X does not run after boot... :(
 
If I remember correctly, 5336 needs major patching to work with that kernel.
You should use 7667, it works perfectly for me

Patator 01-08-06 01:45 AM

Re: Driver 5336 and Mandrake 10.1 - X does not run after boot... :(
 
Quote:

Originally Posted by Dr. Tyrell
If I remember correctly, 5336 needs major patching to work with that kernel.
You should use 7667, it works perfectly for me

That is not an option, 5336 is the only one that worked with my Diamond Viper TNT.

It was supposed to be 6629 but that did not make it. (and believe me I tried)

Beside, it works very fine, my only problem is that something is done during the install that does not last a reboot. What could it be ?

zander 01-08-06 06:57 AM

Re: Driver 5336 and Mandrake 10.1 - X does not run after boot... :(
 
@Patator: my guess is the character specifial files, /dev/nvidia*, are deleted at startup (presumably by udev); you can extract the .run file with the --extract-only option and call the makedevices.sh script (located in the usr/src/nv directory relative to the directory created by --extract-only) from a startup script to work around this problem.

Patator 02-04-06 07:18 AM

Re: Driver 5336 and Mandrake 10.1 - X does not run after boot... :(
 
Thanks it worked perfectly !

I added it to my rc script.


All times are GMT -5. The time now is 05:11 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.