nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-8178 driver don't compile in 2.6.15 amd64 (http://www.nvnews.net/vbulletin/showthread.php?t=62995)

jareguero 01-08-06 05:09 AM

1.0-8178 driver don't compile in 2.6.15 amd64
 
Error:
vmap() appears to be unavailable in this kernel!
Jose Alberto

Enverex 01-08-06 05:36 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
Check your kernel settings, I'm using 2.6.15-ck1 on x86_64 and it works fine for me, seems like you're missing a required kernel option.

zander 01-08-06 05:52 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
@jareguero: if the problem persists, please provide the /var/log/nvidia-installer.log file; note that if you're using Linux >= 2.6.15-git1, you will need to update the NVIDIA driver to account for a recent KBUILD change, see http://www.nvnews.net/vbulletin/showthread.php?t=62889.

jareguero 01-09-06 03:09 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
1 Attachment(s)
Here is the log.
Jose Alberto

zander 01-09-06 04:32 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
@jareguero: which gcc version are you using (`cc -v`)?

jareguero 01-09-06 05:20 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
[root@jar ~]# gcc -v
Usando especificaciones internas.
Objetivo: x86_64-redhat-linux
Configurado con: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --host=x86_64-redhat-linux
Modelo de hilos: posix
gcc versión 4.1.0 20051222 (Red Hat 4.1.0-0.12)

Jose alberto

zander 01-09-06 06:49 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
@jareguero: please see http://www.nvnews.net/vbulletin/show...43&postcount=4.

jareguero 01-09-06 10:49 AM

Re: 1.0-8178 driver don't compile in 2.6.15 amd64
 
Thanks.
It works.
Jose Alberto


All times are GMT -5. The time now is 04:47 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.