nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X doesnt work after restart (http://www.nvnews.net/vbulletin/showthread.php?t=63092)

Blashyrkh 01-10-06 03:17 AM

[solved]X doesnt work after restart
 
Hi folks,

i installed the 8178 version of the nvidia driver with the installer script, on my debian linux system.

thereafter X started without any hassles with startx.

But after restarting the computer X will not come up but report an error

couldn't load module "nvidia".
the only thing that helps thereafter is to run the nvidia.run installer script another time and start x with startx from hand again.
i installed the nvidia module via moduleconf into the kernel but it didnt help.
i tried to load modprobe nvidia, and it via lsmod | grep nvidia i can see that a module nvidia is loaded, but it didnt help.
Everytime the same x-error

i made a nvidia-bugreport.log with the bug report script after restarting my system and running into the error(http://blashyrkh.lodernet.com/nvidia-bug-report.log)

zander 01-10-06 05:35 AM

Re: X doesnt work after restart
 
Judging from the log file, the problem is more likely that X crashes when the GLX module is initialized; did you have Debian's nvidia-glx package installed at some point? If so, does /etc/init.d/nvidia-glx still exist?

Blashyrkh 01-10-06 10:49 AM

Re: X doesnt work after restart
 
the nvidia-glx file exists.
After all i can start X if i install the nvidia Drive, but i have to reinstall it every reboot to get X up.

zander 01-10-06 11:43 AM

Re: X doesnt work after restart
 
The problem should go away after removing that script and reinstalling the driver; it should've been removed as part of the nvidia-glx package, but that unfortunately only happens if you use the apt-get/dpkg --purge command line option.

Blashyrkh 01-10-06 12:17 PM

Re: X doesnt work after restart
 
you mean i should remove the nvidia-glx file? and then reinstall the nvidia driver again?

zander 01-10-06 12:24 PM

Re: X doesnt work after restart
 
Yes, assuming the nvidia-glx package is no longer installed; if in doubt, use `dpkg remove --purge nvidia-glx; rm -f /etc/init.d/nvidia-glx` and reinstall the driver using the .run package.

Blashyrkh 01-14-06 01:46 PM

Re: X doesnt work after restart
 
Thnx that worked out fpor me.
Could you just explain what exactly was the problem?

zander 01-14-06 04:58 PM

Re: X doesnt work after restart
 
The script in question altered the NVIDIA graphics driver installation, resulting in the wrong (for your system) TLS library being used.


All times are GMT -5. The time now is 08:00 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.