nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X freeze (2 video cards) (http://www.nvnews.net/vbulletin/showthread.php?t=63371)

steph-tux 01-15-06 06:14 PM

X freeze (2 video cards)
 
With Mandrake 10.2, the display was perfect in xinerama, with 4 graphic cards. Since I installed Mandriva 2006, I've not been able to use the computer with several graphic cards : X freeze after less than 2 minutes (driver 7664, 7667, 7676 already tried).

ASRock K7S8X, Sempron 2600,
- 1 AGP NVIDIA Geforce 2 MX,
- 3 PCI NVIDIA Quadro 4.

With only one video card, X do not freeze.

I installed the new xorg (6.9), and the new NVIDIA driver (8178), but nothing is better : still freezing with 2 graphic cards.

What could I do to help solve this bug ?

netllama 01-15-06 07:11 PM

Re: X freeze (2 video cards)
 
Please post an nvidia-bug-report.log.

Thanks,
Lonni

kormoc 01-17-06 05:25 PM

Re: X freeze (2 video cards)
 
I as well have this issue. I shall get a debug for you later tonight.

My cards are a AGP 8x FX 5800 and a PCI FX 5200, Xorg 7.0 (Worked fine with 6.8 and below).

kormoc 01-20-06 02:18 AM

Re: X freeze (2 video cards)
 
1 Attachment(s)
Attached is my bug report log. As you can see, I had to disable the second video card in my xorg.conf, and the x error is the pci card's bios can't be read. with xorg 6.8, it worked fine. So, any ideas?

kormoc 01-20-06 02:39 AM

Re: X freeze (2 video cards)
 
1 Attachment(s)
attached is the nvidia_bug_report after the freeze.

netllama 01-20-06 05:18 PM

Re: X freeze (2 video cards)
 
kormoc,
I have a few questions:
0) Does this reproduce without a PRE_EMPT enabled kernel?
1) Does this reproduce without RenderAccel and the Composite extension?
2) How are you using the Coolbits option?
3) Why are you using the ConnectedMonitor option?
4) Does this reproduce without RandR/RandRRotation?
5) What kind of motherboard and BIOS version are you using?
6) Have you tried different values for NvAGP?
7) Have you tried putting the FX5200 in a different PCI slot?

Thanks,
Lonni

kormoc 01-20-06 05:24 PM

Re: X freeze (2 video cards)
 
Quote:

Originally Posted by netllama
kormoc,
I have a few questions:
0) Does this reproduce without a PRE_EMPT enabled kernel?
1) Does this reproduce without RenderAccel and the Composite extension?
2) How are you using the Coolbits option?
3) Why are you using the ConnectedMonitor option?
4) Does this reproduce without RandR/RandRRotation?
5) What kind of motherboard and BIOS version are you using?
6) Have you tried different values for NvAGP?
7) Have you tried putting the FX5200 in a different PCI slot?

Thanks,
Lonni

0) I will try this later tonight. It was working fine for the past bunch of kernel versions fine with PRE_EMPT.
1) Yes, it does
2) I'm not right now. I just have it in there to see the option in nvidia-settings. I havn't used it.
3) With previous driver versions, my monitors would get incorrectly detected, so I just got into the habit of having that in there. Once it starts working again, I'll try without it and see if it works now or not.
4) Yes, it does
5) MSI Neo-FISR (http://www.msi.com.tw/program/produc...il.php?UID=554) Bios verison 3.6 (latest version. Been that version for awhile)
6) Yes, with no change
7) Yes, I have, no change.

netllama 01-20-06 05:30 PM

Re: X freeze (2 video cards)
 
Please remove the ConnectedMonitor option and see if that has any impact.

Also, please try booting with the noapic and/or acpi=off kernel parameters and see if that has any impact.

Thanks,
Lonni

kormoc 01-21-06 12:00 AM

Re: X freeze (2 video cards)
 
it was the apic it would seem. Removing the hard coded connected devices, gives this tho:

(II) NVIDIA(0): Connected display device(s): DFP-0, TV-0
(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0): using first display
(--) NVIDIA(0): Detected TV Encoder: NVIDIA

I don't have a tv hooked up to it, and thus the monitor displays no picture. This on on my FX 5800.

netllama 01-21-06 12:21 AM

Re: X freeze (2 video cards)
 
Just to confirm, booting with noapic fixes the X freeze? If so, then this is likely a BIOS bug.

Thanks,
Lonni


All times are GMT -5. The time now is 02:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.