nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia-settings crashes as soon as it is run (http://www.nvnews.net/vbulletin/showthread.php?t=63506)

Colossus 01-18-06 09:21 AM

nvidia-settings crashes as soon as it is run
 
Hi,

from the command line I get a segmentation fault, this is the backtrace:

Program received signal SIGSEGV, Segmentation fault.
0xb7c6a732 in gdk_window_invalidate_rect () from /usr/lib/libgdk-x11-2.0.so.0
(gdb) bt
#0 0xb7c6a732 in gdk_window_invalidate_rect ()
from /usr/lib/libgdk-x11-2.0.so.0
#1 0xb7e3630a in gtk_text_view_get_default_attributes ()
from /usr/lib/libgtk-x11-2.0.so.0
#2 0xb7b98534 in g_cclosure_marshal_VOID__VOID ()
from /usr/lib/libgobject-2.0.so.0
#3 0xb7b8296c in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4 0xb7b96f7c in g_signal_has_handler_pending ()
from /usr/lib/libgobject-2.0.so.0
#5 0xb7b97ecd in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6 0xb7b9814b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7 0xb7cfb972 in gtk_adjustment_value_changed ()
from /usr/lib/libgtk-x11-2.0.so.0
#8 0xb7cfb9db in gtk_adjustment_set_value () from /usr/lib/libgtk-x11-2.0.so.0
#9 0xb7e31514 in gtk_text_view_new () from /usr/lib/libgtk-x11-2.0.so.0
#10 0xb7e36b9c in gtk_text_view_scroll_to_iter ()
from /usr/lib/libgtk-x11-2.0.so.0
#11 0xb7e36ca1 in gtk_text_view_scroll_to_iter ()
from /usr/lib/libgtk-x11-2.0.so.0
#12 0xb7e36d18 in gtk_text_view_scroll_to_iter ()
from /usr/lib/libgtk-x11-2.0.so.0
#13 0xb7e36d66 in gtk_text_view_scroll_to_iter ()
from /usr/lib/libgtk-x11-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#14 0xb7b19151 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#15 0xb7b15f54 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0xb7b17996 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#17 0xb7b17c15 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#18 0xb7db2483 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x0805b55f in ctk_main ()
#20 0x08052f34 in main ()

I run gtk version 2.8.10. Is it a bug or a misconfiguration of my system ?

zander 01-18-06 11:30 AM

Re: nvidia-settings crashes as soon as it is run
 
1 Attachment(s)
This looks like it might be related to a problem that typically results in asserts; can you try the attached patch to see if it helps? In order to do so, you need to download ftp://download.nvidia.com/XFree86/nv...ngs-1.0.tar.gz and follow these steps:
# tar zxf /path/to/nvidia-settings-1.0.tar.gz
# cd nvidia-settings-1.0
# patch -p0 < /path/to/nvidia-settings-1.0-1418589.diff.txt
# make
# ./nvidia-settings

Colossus 01-19-06 04:33 AM

Re: nvidia-settings crashes as soon as it is run
 
It perfectly worked Zander, thank you so much for your kind reply.

zander 01-19-06 06:59 AM

Re: nvidia-settings crashes as soon as it is run
 
You're welcome. Thank you for your help.


All times are GMT -5. The time now is 11:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.