nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   so let's try this again in the new forum - bad performance with correctly inst.driver (http://www.nvnews.net/vbulletin/showthread.php?t=64)

neutrino 07-28-02 12:15 PM

bad performance with correctly inst.driver
so let's try this again in the new forum. (bad performance with seemingly correctly installed drivers)

here is my problem.

I am trying to play quake 3 but performance is choppy. Not a lot by any means (not like mesa) however enough to make aiming impossible :-(
I have the newest drivers installed, I have checked to see that quake 3 does use the correct libraries. I have tried NvAGP and AGPGART, I have experimented with nvclock. all to no avail.

I have a geforce 4 Ti4200 an athlon XP 1800+ 512MB DDRSDRAM SuSE 8.0 so it shoud run fine and anyway this happens at all resolutions and even at lowest detail levels (picmip 5!!).

if you have any ideas please please please help.


PS I've set the drawFPS option to true in quake 3. the numbers change so fast I can't read anything - it just looks like 88. I remember somebody else on the former message board had the same effect but I don't know if any solution was found.

PPS greetings to DarkLLord

Thunderbird 07-28-02 04:30 PM

Well 88 isn't choppy. Perhaps you aren't using DGA mouse support in quake3. DGA mouse provides you with a smooth moving mouse (good for aiming ..). Perhaps is that the real problem you have. Check what the value for in_dgamouse is set too. If it is 1 it is good.

neutrino 07-28-02 04:38 PM

you misunderstand...
it's not at 88, just the numbers change so fast you can't read the values....
and I have also tried without using the mouse - navigating with the keyboard yields the same choppyness.

neutrino 07-29-02 06:26 AM

and perhaps I should add...
... a section from /var/log/XFree86.0.log

as you see everything seems correct, only that it doesn't work! argh!!!!!!!! :-(

(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.2960
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) NVIDIA XFree86 Driver 1.0-2960 Tue May 14 07:45:20 PDT 2002
(II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, Vanta,
RIVA TNT2 Ultra, RIVA TNT2 Model 64, Aladdin TNT2, GeForce 256,
GeForce DDR, Quadro, GeForce2 MX/MX 400, GeForce2 MX 100/200,
Quadro2 MXR/EX/Go, GeForce2 Integrated GPU, GeForce2 GTS,
GeForce2 Ti, GeForce2 Ultra, Quadro2 Pro, GeForce4 MX 460,
GeForce4 MX 440, GeForce4 MX 420, Quadro4 500/550 XGL,
Quadro4 200/400 NVS, GeForce3, GeForce3 Ti 200, GeForce3 Ti 500,
Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400, GeForce4 Ti 4200,
Quadro4 900 XGL, Quadro4 750 XGL, Quadro4 700 XGL, GeForce2 Go,
GeForce4 440 Go, GeForce4 420 Go, GeForce4 420 Go 32M,
GeForce4 440 Go 64M, Quadro4 500 GoGL
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset GeForce4 Ti 4200 found

and from the XF86config

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "5"
Option "Device" "/dev/mouse"
Option "InputFashion" "Mouse"
Option "Name" "AutoDetected"
Option "Protocol" "imps/2"
Option "Vendor" "AutoDetected"
Option "ZAxisMapping" "4 5"

Section "Device"
BoardName "GeForce4 Ti 4200"
Driver "nvidia"
Option "NoLogo" "true"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
Option "NvAgp" "1"

ls /usr/local/games/quake3/ -l
lrwxrwxrwx 1 root root 17 Jun 17 19:29 libGL.so -> /usr/lib/libGL.so

ls -l /usr/lib/libGL.so*
lrwxrwxrwx 1 root root 17 Jul 21 18:55 /usr/lib/libGL.so -> libGL.so.1.0.2960
lrwxrwxrwx 1 root root 27 Jul 22 18:04 /usr/lib/libGL.so.1 -> GL/libGL.so.1.0.2960.nv_glx
-rwxr-xr-x 1 root root 281244 Jul 21 18:55 /usr/lib/libGL.so.1.0.2960

and yes quake 3 uses the correct libraries. I've even tried in another windowmanager so that quake 3 was the *only* app using GL ... same problems.

Thunderbird 07-29-02 06:51 AM

If you really think the problem is opengl related (which I doubt) you can do an updatedb. Then do a locate libGL to find all libGL related files.

I would remove the libGL.so from the quake3 dir since that one isn't needed.

Why don't you run a timedemo in quake3?
For 1.31 it is possible to run them. Here's a quick howto:
- rename pak6.pk3 from the baseq3 to pak6.zip.
- unzip the zip file to a temp dir
- create a dir baseq3/demos (in the quake3 dir)
- copy the file four.dm66 (from the temp/demos dir) to baseq3/demos
- rename four.dm66 to four.dm67
- rename pak6.zip back to pak6.pk3
- run quake3
- enter in the console "timedemo 1"
- then in the console: "demo four"
- after the demo check your fps

neutrino 07-29-02 08:34 AM

I get 88.6 fps

1260 frames, 14.2 seconds: 88.6 fps
at 1280x1024 high detail level.

but the game is not playable. performance is very jagged - choppy

any ideas? (*please*)


PS I really don't want to have to boot into *another* OS :-(

PPS I can leave the libGL in the quake 3 directory. I put it there originally to force quake 3 to use the correct lib...

quake3 log

neutrino@linux:/usr/local/games/quake3/baseq3> quake3
Q3 1.31 linux-i386 Dec 17 2001
----- FS_Startup -----
Current search path:


4064 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
Joystick is not active.
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 8: 1280 1024
Using XFree86-VidModeExtension Version 2.1
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 1280x1024
Using 4/4/4 Color bits, 16 depth, 0 stencil display.
GL_RENDERER: GeForce4 Ti 4200/AGP/3DNOW!
Initializing OpenGL extensions
...ignoring GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
XF86 Gamma extension initialized

GL_RENDERER: GeForce4 Ti 4200/AGP/3DNOW!
GL_VERSION: 1.3.1 NVIDIA 29.60


PIXELFORMAT: color(16-bits) Z(16-bit) stencil(0-bits)
MODE: 8, 1280 x 1024 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: disabled
Initializing Shaders


----- finished R_Init -----

------- sound initialization -------
----- Sound Info -----
sound system is muted
1 stereo
32768 samples
16 samplebits
1 submission_chunk
22050 speed
0x4d2b2000 dma buffer
No background file.
Sound memory manager started
Loading vm file vm/ui.qvm.
VM file ui compiled to 581971 bytes of code
ui loaded in 1943200 bytes on the hunk
35 arenas parsed
32 bots parsed
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: linux.local
Alias: linux
Started tty console (use +set ttycon 0 to disable)

Thunderbird 07-29-02 08:40 AM

Your framerate is great. Perhaps you mean with choppy the "bad" ping you get when playing online. Check if you choppy problem occurs when playing against normal bots locally.

neutrino 07-29-02 09:09 AM

it's not a lag issue.

and I repeat: even if q3 claims to be doing a high framerate. it isn't true!
the screen just doesn't refresh at 80 FPS! performance really is choppy!

this is not lag.

ping localhost
PING localhost ( from : 56(84) bytes of data.
64 bytes from localhost ( icmp_seq=1 ttl=255 time=0.040 ms

actually it felt like lag at first compelling to ping myself just to make sure it's not ;)
and when playing on a laggy connection the lags (jumps) occur more randomly. I get little 'jumps' regularly ~4-6 times a second (that's how it feels anyway) [the slideshow effect?]

/me boots win98 :(

Thunderbird 07-29-02 09:36 AM

The screen only refreshes at for example 85 fps when you use 85 Hz for your monitor. Perhaps what you see is a "vsync" problem. Try to set the following environment variable: __GL_SYNC_TO_VBLANK=1.

DarkLLord 07-29-02 10:42 AM

Dude, I do hope that you will get that problem fixed ASAP

And whether you start counting depends on whether you dream in C or in Delphi :-))

neutrino 08-01-02 12:49 PM

__GL_SYNC_TO_VBLANK=1 is set
doesn't help.

I'm starting to think the problem is somewhere totally obscure that has nothing to do with the drivers...
I mean: I've tried *everything*...

does anyone have any other ideas what I could try?


DarkLLord 08-01-02 04:19 PM

Already tried setting it to 0 (== OFF ?!?)

All times are GMT -5. The time now is 04:23 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.