nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   6600 GT PCIE Sol 10 u1 - errors (http://www.nvnews.net/vbulletin/showthread.php?t=64283)

mschulz 02-02-06 06:13 PM

6600 GT PCIE Sol 10 u1 - errors
So I have this new kit with an AMD 4400 x2, a MSI NEO-4F Mobo and this 6600 GT graphics card, works nice on WinXP and Linux Suse10 :)

I download Solaris 10 latest update and get the non-graphical setup :cool:

Reboot, fix Grub, reboot and there I am in the black box 40x80 :(

Look at the Xorg start log, which shows it can't find the 'keyboard'
driver, fix it to 'kbd', try again, it still crashes (got stack trace) somewhere
in NDD probing, one call down from the nv driver. :thumbdwn:

Google to the rescue (do that from the command line!).
Find the forum here and see there are similar problems all round, but not
exactly like this, and no exact cure either.

Download the three year old, 4.0 driver fom nvidia, and ...
it cannot find the screen !? (and has the same 'keyboard' issue!?).

There's also a funky message in the log about a missing /dev/nvidactl
device. Wasn't that part of the install? So what gives?

Which is the 'right' way to go, should both drivers work, what am I doing
wrong or is it just me being at the right place but the wrong time?

I read the posting over at yahoo Solaris x86, but can't make anything of
the advice re. creating the device files and links, it's all chinese to me.

Same for the nvidia required devices, the magic '"00de,140"'. Anybody bother
to explain? What would the 3-year old driver know about PCIE and Solaris 10 anyway?

Sorry for the longwinded rant - I can actually come up with some real information, if anybody's interested.

Thanks for reading all of it.


mschulz 02-02-06 09:11 PM

Re: 6600 GT PCIE Sol 10 u1 - errors
1 Attachment(s)
uh, sorry, didn't mean to insult the folks from nvidia - just got confused by the zandar's 'join' date vs the post date of the driver announcement.

anyhow, here's the log file:

mschulz 02-02-06 09:34 PM

Re: 6600 GT PCIE Sol 10 u1 - errors
scanpci output:
pci bus 0x0005 cardnum 0x00 function 0x00: vendor 0x10de device 0x0140
nVidia Corporation Device unknown

/devices/pci@5,0 does not exist.

What does that mean?

zander 02-03-06 07:14 AM

Re: 6600 GT PCIE Sol 10 u1 - errors
How did you install the NVIDIA Solaris graphics driver? Please generate a bug report log file with `nvidia-SunOS-bug-report.sh` and attach it - the Xorg log file you attached appears to be from a Linux installation.

mschulz 02-04-06 10:10 PM

Re: 6600 GT PCIE Sol 10 u1 - errors
Well I played around some more and finally succeeded, if in very convoluted way.

First, however, let me mention that I never ever got the Xorg nv driver working.

Second, I found the overall behavior of the installers and Xorg quite quirky,
some of it surmountable with some basic commands.

So how did I get a working X driver set up?

1) Install Solaris 10 3/5. Using the console text install, as the
X window came up, but did not accept keyboard input.
Get your partions righ the first time round, as the reshuffling excercise
which ensues during an upgrade is not woth the trouble.
That means, min 6GB for the root, if you want the companion disk
content installed.
Note that at that point I didn't have a working network connection,
via the nge0 device - not sure whether that's a excercise of simple
'plumb'ing or unsupported. Works fine in 1/6.

2) Install the NVIDIA package. Sweet and easy. reboot. Working.

3) Upgrade to Solaris 10 1/6. That definitely took some time, but worked
OK. Btw. that's console text based again.

4) At this point, starting the Xorg server failed, and I did not get it working
but also didn't try very hard. I think among other things the file
/etc/driver_aliases was overwritten by the upgrade.
Install companion software.

5) Reinstall the NVIDIA package. reboot. Working.

6) Cleanup, set the keyboard correctly, plumb the networking, reconfigure
the system etc.
I also installed the latest patches for the kernel and Xorg and device

Bottom line is I don't know why 1/6 did not work for me in the first place.
And why it works now. Pobably easy to figure out with full knowledge of
the required device files and config - which I don't have.

The only issue I'm having is 640 x 400 mode as my monitor is not communicating to the driver. Not sure why my config doesn't overwite it.

Thanks for reading to the end.
Sorry for not reporting the problem properly - all this took a lot more time
than I tought it would and I won't reinstall just for that.


All times are GMT -5. The time now is 03:46 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.