nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   kernel header file does not exist (http://www.nvnews.net/vbulletin/showthread.php?t=64286)

tehmay00 02-02-06 08:01 PM

kernel header file does not exist
 
I am quite the linux noob, but am trying to learn so please be patient with me.
I am attempting to install the latest nvidia drivers

Here is a bit of info :

uname -r
2.6.15-1.1826.2.10_FC5

ls /usr/src/
linux-2.6.15.1 linux-2.6.15.1.tar

i start the driver install by point --kernel-source-path to /usr/src/linux-2.6.15.1
this is the error it spits out at me

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Feb 2 19:47:48 2006

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : /usr/src/linux-2.6.15.1
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Performing CC test with CC="cc".
-> Using the kernel source path '/usr/src/linux-2.6.15.1' as specified by the
'--kernel-source-path' commandline option.
ERROR: The kernel header file '/usr/src/linux-2.6.15.1/include/linux/version.h'
does not exist. The most likely reason for this is that the kernel
source files in '/usr/src/linux-2.6.15.1' have not been configured.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.



for some reason it is saying i don't have the kernel header file version.h
when i check the directory that its suppose to be in.... its not there.

can anyone please help me with this problem.

Thanks

netllama 02-02-06 08:05 PM

Re: kernel header file does not exist
 
You need to install the kernel-devel RPM.

-Lonni

tehmay00 02-02-06 08:16 PM

Re: kernel header file does not exist
 
any idea where i would get this

been searching for it with no luck

PhunkMaster 03-05-07 03:53 AM

Re: kernel header file does not exist
 
I hope that posting is this tread isn't bad thing seeing as how I have the exact same problem except I have the kernel-source rpm installed and i made sure that kernel.h is in the /usr/src/linux-2.6.18.2-34/include/linux/ path. I have run
'sh NVIDIA-Linux-x86-1.0-7182-pkg1.run --kernel-source-path /usr/src/linus-2.6.18.2-34/'
and
'sh NVIDIA-Linux-x86-1.0-7182-pkg1.run --kernel-source-path /usr/src/linus-2.6.18.2-34/'

And I keep getting the same error telling me that it cannot find teh header files. I am using the older version beacuse that seems to be the last versio0n taht support th nVidia Gforce 4 440 go. I have tried the newer one (9746) and x will never load video. ( I tried to do this through YAST) I have also ran the installer for the 9631 build and the same thing happens it will compile and install but x will never show video. But I as soon as I try to complie the 7182 build I get this error message. I have tried doing them one after the other in backwards order and that did not work so i did a fresh install of suse 10.2 and tried again and it still is giving me the same error.
================================================== ===
Edit:
Soultion found here: http://www.nvnews.net/vbulletin/showthread.php?t=77433


All times are GMT -5. The time now is 04:53 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.