nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   [Upgraded to 2.6, kernel module build error] (http://www.nvnews.net/vbulletin/showthread.php?t=64371)

BSD 02-04-06 04:07 PM

[Upgraded to 2.6, kernel module build error]
 
1 Attachment(s)
I just upgraded to the 2.6 kernel, and everything except the nvidia kernel module seems to work. I used the nvidia .run installer to install the latest linux drivers, but it said: ERROR: unable to build the nvidia kernel module.
I attached the nvidia-installer.log file. All help is greatly appreciated.

zander 02-04-06 05:07 PM

Re: [Upgraded to 2.6, kernel module build error]
 
This looks like a problem with the kernel source tree you're building against:


/usr/src/linux-2.6.15.2/Makefile modules
/usr/src/linux-2.6.15.2/Makefile:486: .config: No such file or directory
...
make -rR -f /usr/src/linux-2.6.15.2/scripts/Makefile.modpost
/usr/src/linux-2.6.15.2/scripts/Makefile.modpost:38: .config: No such file or directory
make[4]: *** No rule to make target `.config'. Stop.

BSD 02-04-06 10:34 PM

Re: [Upgraded to 2.6, kernel module build error]
 
What do you suggest I do to fix this problem? What is wrong with it? I'm pretty sure I had the same problem with 2.6.13 ( I could be wrong).

zander 02-05-06 09:04 AM

Re: [Upgraded to 2.6, kernel module build error]
 
You need to install the correct configuration file as .config and configure the kernel source tree (this used to be possible with `make prepare-all`, but the KBUILD rules may have changed recently). Alternatively, rebuild/reinstall your kernel and be sure not to clean it with `make mproper` afterwards.

BSD 02-05-06 02:10 PM

Re: [Upgraded to 2.6, kernel module build error]
 
Quote:

Originally Posted by zander
Alternatively, rebuild/reinstall your kernel and be sure not to clean it with `make mproper` afterwards.

I actually did make mrproper before I compiled. I did it in this order:
make mrproper
make menuconfig
make -j5 bzImage
make -j5 modules
make modules_install
move system.map, bzimage, vmlinuz to /boot
lilo
rm /etc/modprobe.conf
generate-modprobe.conf
depmod 2.6.15.2

Is it not correct?

BSD 02-05-06 10:04 PM

Re: [Upgraded to 2.6, kernel module build error]
 
Alright, now how do I have the nvidia module installed for both 2.4 and 2.6. Everytime I boot 2.4 now, I have to re-install the drivers to startx (and same if I switch back to 2.6). Thanks for your help.

zander 02-06-06 07:39 AM

Re: [Upgraded to 2.6, kernel module build error]
 
After you've installed the driver with either kernel running, you can add a kernel module for the other to the installation with nvidia-installer's -K option.


All times are GMT -5. The time now is 07:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.