nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Slackware 8.1 - nvidia driver... (http://www.nvnews.net/vbulletin/showthread.php?t=6440)

newux 01-19-03 01:38 PM

Slackware 8.1 - nvidia driver...
 
Hi
I have a lot of problems by configuring the x-window in slackware 8.1. My monitor is really old and I didn't know my horizontal and vertical range, so I installed redhat and I noticed my horizontal range is 31.5 - 48.5 and my vertical 50 - 70. First I tried with the nv and it didn't work. Then I tried with the nvidia and i have this error: No drivers available. No screens were found. I've tried with the nv_check.sh and it says that the modules are not loaded. I try to load it with intmod but it doesn't work.
I have a P3 866Mhz 128Mb with a NVidia G-force MX 400/400. I've tried all but I don't know what I do wrong. What can I do??? :(
Sorry because of my english...

Ryo-Ohki 01-19-03 03:38 PM

Okay, let's do this by the book. First of all, are you back under Slackware or still running RedHat ? Which drivers did you get for your card ?

Running a GeForce under Slackware is a breeze - trust me, I know... :type:

newux 01-19-03 04:57 PM

Yes, now I'm back under Slackware. First I tried to configure the X with "nv" and then with "nvidia" and I've had problems with both... :confused:

Ryo-Ohki 01-20-03 02:27 AM

Okay.

What I did :

Go to www.nvidia.com and download the latest drivers (1.0-4191). You need the NVIDIA_kernel driver AND NVIDIA_GLX driver. With Slackware, always get the tarballs. Also download the PDF file with the instructions.

Kernel source tarball driver
GLX tarball driver
PDF help file

cd to the directory where you saved the above files and type :

root@yourmachine# tar -xvzf NVIDIA_kernel-1.0-4191.tar.gz
root@yourmachine# tar -xvzf NVIDIA_GLX-1.0-4191.tar.gz

Enter the NVIDIA_kernel directory :

root@yourmachine# make
root@yourmachine# make install
(disregard the tainted kernel warning)

Then go to the NVIDIA_GLX directory :

root@yourmachine# make (or make install, both should work)


Then you can generate an XF86Config file. Type "xf86config" at the prompt, input all requested info except for the vid card - bypass the section. Once done, emacs /etc/X11/XF86Config and modify values according to the PDF instructions :

- find references to Driver "vga" (which you should find two instances of if you follwed my instructions above) and replace them with "nvidia".
- uncomment Load "glx"
- there shouldn't have any Load "dri" or Load "GLcore" lines to remove, but check anyway.

Save, you should be done.

root@yourmachine# startx will tell you in no time... :D (modify the /etc/inittab file to start up in X mode automatically, runlevel 4 will do the job).

Let me know how it goes.

newux 01-20-03 08:05 AM

Well, I've done all you said me but...
(EE) No drivers available

Fatal serer error:
no screens found

Then I do a lsmod and...
root@evil:~# lsmod
Module Size Used by No tainted
root@evil:~#

NO MODULE!!! :(
What do I do wrong???

bwkaz 01-20-03 11:36 AM

What was the output of the make in the NVIDIA_kernel directory?

newux 01-20-03 12:02 PM

1 Attachment(s)
ld -r -o nvidia.o nv-linux.o nv-kernel.o
size nvidia.o
text data bss dec hex filename
1248527 9824 32940 1374291 14f853 nvidia.o
depmod: *** unresolved symbols in /lib/modules/2.4.18/pcmcia/paport-cs.o.gz
make: *** [package-install] Error 1

That's the output of the make and the nv_check_new.sh says this:
All the files seem to exist. Now I'm going to see if your kernel
module can be loaded correctly...
The nvidia.o kernel module does not seem to be loading. The 3D
drivers will not work without it...please compile it for your
kernel, set it up to insert the module on boot, then run
this script again.
Remember if you are having trouble compiling the module,
try adding -D_LOOSE_KERNEL_NAMES to the Makefile.

I attach my XF86Config file because I don't know more what to do...

Ryo-Ohki 01-20-03 03:17 PM

Quote:

Originally posted by newux
ld -r -o nvidia.o nv-linux.o nv-kernel.o
size nvidia.o
text data bss dec hex filename
1248527 9824 32940 1374291 14f853 nvidia.o
depmod: *** unresolved symbols in /lib/modules/2.4.18/pcmcia/paport-cs.o.gz
make: *** [package-install] Error 1

Uuh... This doesn't sound too good. Is the kernel file actually generated, or can you even find it under /lib/modules/2.4.18 ?

What's the output of the following command :

root@yourmachine# insmod nvidia

bwkaz 01-20-03 03:45 PM

What about /sbin/insmod nvidia?

parport_cs.o.gz does not, repeat not have anything to do with the nVidia drivers, it's a parallel port driver. ;)

newux 01-20-03 04:17 PM

root@evil:~# insmod nvidia
Using /lib/modules/2.4.18/kernel/drivers/video/nvidia.o
Warning: loading /lib/modules/2.4.18/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#s1-18 for information about tainted modules
Module nvidia loaded, with warnings

root@evil:~# lsmod
Module Size Used by Tainted: P
nvidia 1467488 0 (unused)

root@evil:/lib/modules/2.4.18# ls -l
total 48
lrwxrwxrwx 1 root root 21 Jan 19 19:58 build -> /usr/src/linux-2.4.18/
drwxr-xr-x 3 root root 4096 Jan 19 19:58 kernel/
-rw-r--r-- 1 root root 4839 Jan 20 18:47 modules.dep
-rw-r--r--
1 root root 31 Jan 20 18:47 modules.generic_string
-rw-r--r-- 1 root root 73 Jan 20 18:47 modules.ieee1394map
-rw-r--r-- 1 root root 81 Jan 20 18:47 modules.isapnpmap
-rw-r--r-- 1 root root 29 Jan 20 18:47 modules.parportmap
-rw-r--r-- 1 root root 295 Jan 20 18:47 modules.pcimap
-rw-r--r-- 1 root root 24 Jan 20 18:47 modules.pnpbiosmap
-rw-r--r-- 1 root root 189 Jan 20 18:47 modules.usbmap
drwxr-xr-x 2 root root 4096 May 31 2002 net/
drwxr-xr-x 2 root root 4096 May 31 2002 pcmcia/

it's loaded but the error with startx is the same :(
What's the problem now? Have you any idea? I really not...

bwkaz 01-20-03 06:01 PM

Try a startx, then attach /var/log/XFree86.0.log. If the error is related to "failed to initialize kernel module", then look through about the last 350 lines of /var/log/messages (actually, ... attach those last 350 lines as well).

Ryo-Ohki 01-21-03 02:12 AM

Quote:

Originally posted by bwkaz
What about /sbin/insmod nvidia?

insmod alone works perfectly fine with Slackware. ;)

Besides, newnux, did you launch the "make install" command just after you compiled the kernel module (in the NVIDIA_kernel directory) ? If you do it, what's the output of the command ? I'm mystified the module doesn't load at startup like it should do.

At least we know it does exist and that you can load it manually... There's hope left. ;)

One question though, do you still get the "(EE) no drivers available" upon executing startx, or just "no screens found" ?

I'd suspect an XF86Config setup issue, even if I can't see the problem right now. I'll cross-check the one you posted above with mine at home.


All times are GMT -5. The time now is 02:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.