nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Legacy Graphics Cards (http://www.nvnews.net/vbulletin/forumdisplay.php?f=37)
-   -   riva tnt + gentoo 2005.1 (http://www.nvnews.net/vbulletin/showthread.php?t=64410)

rko15 02-05-06 09:49 AM

riva tnt + gentoo 2005.1
 
I just installed gentoo 2005.1 (kernel 2.6.12-gentoo-r6) on my 7-year-old dell xps r450 (pentium 2, 450 MHz), which has a riva tnt video card (agp, 16 MiB ram). Graphics work fine with the generic nv driver (except for the usual black strip at the left), but when I install the nvidia driver, all I get is a black screen.

I meticulously followed the instructions in the Gentoo linux nvidia guide:
http://www.gentoo.org/doc/en/nvidia-guide.xml. Everything went well (emerge nvidia-glx; modprobe nvidia; edit /etc/modules.autoload.d/kernel-2.6, adding nvidia; modules-update; edit /etc/X11/xorg.conf, changing the driver from nv to nvidia, commenting out Load "dri" in the Module section, and making sure DefaultDepth was set to 24; opengl-update nvidia) until the moment of truth when I gave the startx command. Then all I got was a black screen.

Question: Is it possible to get the nvidia driver to work with the 2.6.12-gentoo-r6 kernel and the riva tnt card? And of course, if possible, I would like to hear from someone who has actually accomplished this.

(According to the various README files, all the unified ia32 linux display drivers up through version 1.0-7174 (31 Mar 2005), and in particular version 1.0-6629 (5 Nov 2004) which comes with gentoo 2005.1 and the 2.6.12-gentoo-r6 kernel, support the riva tnt card. See http://www.nvidia.com/object/linux_display_archive.html.)

TimsonC2000 03-04-06 11:08 AM

Re: riva tnt + gentoo 2005.1
 
i have the same problem - any body who can help?


message from xorg.log:

Failed to initialize the NVIDIA kernel module!
Screen found, but none have a usable configuration

logistiker 06-09-06 11:02 AM

Re: riva tnt + gentoo 2005.1
 
You should use the 7174 driver. You might have to ~x86 keyword it so you can emerge it as it's not stable yet but should be set to stable soon. You have to emerge two packages as well: nvidia-kernel and nvidia-glx.


All times are GMT -5. The time now is 03:44 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.