nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Glx crashes x just after nvidia logo, works fine withouth glx enabled (http://www.nvnews.net/vbulletin/showthread.php?t=64463)

and_jel 02-06-06 09:18 AM

Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
1 Attachment(s)
I installed the x86_64-1.0-8178 driver on a debian sid system using the nvidia installer. Unfortunately, X only starts properly with glx disabled. Everything else works at it should, 2d acceleration works fine.
I attached the Xorg logfile. I would greatly appreciate any kind of help and suggestions.
Btw the system is pentium D with 64 bit debian sid and a 6600 nvidia card. A build in video card is also present on the motherboard (intel).

netllama 02-06-06 10:38 AM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
Please generate and provide a full bug report.

Thanks,
Lonni

kcary 02-06-06 01:12 PM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
1 Attachment(s)
I am having this exact same problem. I am using a 6800 GT PCI-Express card and my full log file is as follows:

Attachment 16054

When I run it without glx enabled everything seems to work fine. The only thing I really noticed in the log was one place it says "nVidia Corporation unknown chipset ..."
Let me know if you need any other information.

and_jel 02-06-06 05:22 PM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
5 Attachment(s)
I'm not exactly sure what constitutes a full bug report. Do i send one to somewhere else than this forum?
I attached more information about my systems configuration, both software and hardware. If you need any more just ask. I can easily recreate the problem just by uncommenting
#Load "glx"
so if you need some extra information about the crash it wont be a problem, i just don't know anything about debugging this kind of thing.

dpk list.txt.zip is a list of all the packages installed on my pc and their version.
lspci vv.txt is the output from running lspci -vv.
config.txt is my kernel configuration.

Thank you for your interest

netllama 02-06-06 05:48 PM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
nvidia-bug-report.log is a full bug report. Please see the README if you're not sure how to generate one.

Thanks,
Lonni

and_jel 02-07-06 07:54 AM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
2 Attachment(s)
Alright, so here are to full bug reports as generated by nvidia-bug-report.sh.
nv-report.noglx.txt was generated with the xserver running.
nv-report.glx.txt was generated just after causing the xserver to missfire by enabling glx in xorg.conf.

Thank you for your help.

netllama 02-07-06 12:35 PM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
To confirm, you are seeing this issue immediately after installing the driver?

If so, can you try using the --force-tls installation option, first with 'classic', and if the problem persists, install again with 'new'.

Thanks,
Lonni

and_jel 02-07-06 03:21 PM

Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled
 
Yes immediately after.
I tried reinstalling the driver with the options you suggested, but the problem persisted.

Best regards
Anders


All times are GMT -5. The time now is 10:40 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.