nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Failed to load the NVIDIA kernel module! (http://www.nvnews.net/vbulletin/showthread.php?t=64491)

Chris97b 02-06-06 06:30 PM

Failed to load the NVIDIA kernel module!
 
Hello all,

Been beating my head on the desk for a few days on this one.

I'm running FC4 (kernel 2.6.15-1-1830), trying to install the Nvidia driver (8178, using the installer from nvidia.com) for a GeForce 5500.

The installer seems to run fine, but when I try to start X, it crashes with the error: Failed to load the NVIDIA kernel module!

a modprobe nvidia results in the error: Module nvidia_1_0_8178 not found


I ran the nvidia-bug-report script, the output is at:

http://pastebin.ca/40433

(this output includes the contents of nvidia-installer.log)


At the suggestion of a friend, I'm recompiling the kernel without framebuffer at the moment, but has anyone seen this before?

I've tried several different modifications to xorg.conf I've found crawling the web, none of which seem to help. I'm just about at my wits end :banghead:


Thanks,
-Chris

netllama 02-06-06 06:35 PM

Re: Failed to load the NVIDIA kernel module!
 
Check your /etc/modprobe.conf. Some 3rd party nvidia driver packages put an nvidia kernel module alias for nvidia_1_0_8178 in there which should not be there.

-Lonni

Chris97b 02-06-06 08:19 PM

Re: Failed to load the NVIDIA kernel module!
 
Well, that fixed that problem, thx!

But now I'm having the same issue I did with the 3rd party modules; X locks up loading.

It looks like a dialog/warning box pops up, but the 'fedora core' loading screen covers it up, and X is hung, so I cannot bring it to the front.


I have included another bug report. If anyone has any more ideas, I would appreciate it

-Chris

nvidia-bug-report.log:

http://pastebin.ca/40456

netllama 02-06-06 09:49 PM

Re: Failed to load the NVIDIA kernel module!
 
What kind of motherboard are you using, and which BIOS version?

-Lonni

Chris97b 02-07-06 07:23 AM

Re: Failed to load the NVIDIA kernel module!
 
Honestly, I think I've narrowed it down to the board

It's a *really* old ECS Socket A board (not sure of the specific model/BIOS; will check when I get home)

I'm going to a friends place today or tomorrow to test the card in his sytem, should show if it's the mobo :)


Thanks again,
-Chris

Chris97b 02-07-06 12:50 PM

Re: Failed to load the NVIDIA kernel module!
 
OK, found a little more information on the motherboard.

It's an ECS K7SEM (PC Chips M810LMR) w/ a SIS7018 chipset. Still not sure what the specific BIOS is on it, but I'm almost positive it has never been updated.

A Tech site on this motherboard (http://radel.inet.net.nz/m810lmr.html) suggested using a beefy power supply when using an AGP card (the motherboardboard has onboard VGA) and forcing 1X AGP.


As soon as I get off of work, I'm going to swap the PSU for a 400W and try updating the BIOS. As for 1X AGP, I'm not certain this is something I can do from the BIOS (the site I found indicates that for windows users, a registry hack is the best way to do it)


Does anyone know of a software method to force 1X AGP? Is this one of the options I can pass to the nvidia driver in xorg.conf?

I'll update this as soon as I can try those out.


-Chris

netllama 02-07-06 01:20 PM

Re: Failed to load the NVIDIA kernel module!
 
You can disable AGP from the driver by setting NvAGP=0, however you cannot specify specific AGP bus rates. Some BIOS's allow you to set the AGP bus rate.

-Lonni

Chris97b 02-07-06 04:26 PM

Re: Failed to load the NVIDIA kernel module!
 
WOOHOO!!!

Setting NvAGP=0 did the trick!

glxgears gives me an average FPS over 1,300! (As opposed to ~130 with the stock 'nv' driver)

Thanks Lonni,

-Chris


All times are GMT -5. The time now is 03:26 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.