nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   Fatal server error: no screens found / Syncmaster 913v (http://www.nvnews.net/vbulletin/showthread.php?t=64585)

birke 02-08-06 08:08 AM

Fatal server error: no screens found / Syncmaster 913v
 
I just successfully installed the display driver which I downloaded from
http://www.nvidia.com/object/solaris..._1.0-7664.html

I am using a GeForce4 MX440 AGP 8X with 64MB memory and a Samsung Syncmaster 913v tft display.

Everything worked well.

I see that the kernel wants to load the driver during reboot.

But at the end I get the following error messages on the screen:


When I look at the Xorg.0.log file I see

(II) NVIDIA dlloader X Driver 1.0-7664 Wed May 25 11:09:14 PDT 2005
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
....
....
(II) Setting vga for screen 0.
(++) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Does someone knows which changes to make ?

thanks,
regards,
B.

patmartini 02-13-06 10:59 PM

Re: Fatal server error: no screens found / Syncmaster 913v
 
1 Attachment(s)
Quote:

Originally Posted by birke
I just successfully installed the display driver which I downloaded from
http://www.nvidia.com/object/solaris..._1.0-7664.html

I am using a GeForce4 MX440 AGP 8X with 64MB memory and a Samsung Syncmaster 913v tft display.

Everything worked well.

I see that the kernel wants to load the driver during reboot.

But at the end I get the following error messages on the screen:


When I look at the Xorg.0.log file I see

(II) NVIDIA dlloader X Driver 1.0-7664 Wed May 25 11:09:14 PDT 2005
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
....
....
(II) Setting vga for screen 0.
(++) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Does someone knows which changes to make ?

thanks,
regards,
B.


Hello. I have the same problem, which I have been working on for three weeks. I have tried numerous xorg.conf configurations and changes, just to see what would happen - I always end up with 'Sreens found, but none have a usable configuration.'

I find it interesting that this post has sat almost a week without a single response. I think nVidia under Unix/Linux may be just too much trouble. I have uploaded the xorg.conf example, and was going to upload the Xorg.0.log file, but I can't get to that one at the moment.

If someone might look at the xorg.conf file and let me know of any glaring errors, I would really appreciate it! Thank you,

pm..

tarzanek 02-15-06 05:53 PM

Re: Fatal server error: no screens found / Syncmaster 913v
 
:)
guys, you could just consult the README & you would see, that for some reason nvidia kernel driver doesn't attach, therefore Xorg is unable to communicate with it ...
try using the newest drivers(which have already some of the driver_aliases), or check some other msges in this forum on howto manually attach driver to kernel

hth

toddbailey 11-01-09 10:28 AM

Re: Fatal server error: no screens found / Syncmaster 913v
 
well here it is a few years later and problem is still occurring.

this time with a 9800gt with 190.42 drivers and a hdmi connection
185.31 works ok, but no audio over hdmi

190.42 worked once, but after a reboot nothing

very frustrating.


All times are GMT -5. The time now is 04:36 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.