nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Artifact on screen when leaving X? (http://www.nvnews.net/vbulletin/showthread.php?t=6519)

douga 01-21-03 10:18 AM

Artifact on screen when leaving X?
 
I'm using the newest nvidia driver on my machine with Slackware 8.1. I have the kernel compiled to NOT use AGP, and I don't have any AGP settings in my XF86Config. I DO have glx loaded.

When I exit X, I sometimes get a rectangle of color in the lower right hand quarter or eighth of the screen. If I then startx again, I rectangle may move, but it doesn't go away. I'm using the Riva TNT card that came with my Dell (about two years old, I think).

Anyone seen anything like this?

Thanks for any help.

michal017 01-27-03 07:35 AM

I'm seeing a similar problem.. when leaving X (sometimes) I have sort of shadow on the screen so I can't see the console.

Some guy suggested to 'reset the DRI (or was it Xv?) memory space correctly' but I don't know how to do that ;)

douga 01-27-03 09:05 AM

Quote:

Originally posted by michal017
I'm seeing a similar problem.. when leaving X (sometimes) I have sort of shadow on the screen so I can't see the console.

Some guy suggested to 'reset the DRI (or was it Xv?) memory space correctly' but I don't know how to do that ;)

I found *a* solution to this problem, but I don't know if it's *the* solution.

First off, I had to load the nvidia module last in rc.modules. Then, I set NvAGP to "1" in my XF86Config, and recompiled my kernel so that it didn't support AGP.

As far as the DRI goes, I know that if you have a line that says "load dri" in your XF86Config, you should comment it out.


All times are GMT -5. The time now is 10:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.