nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Kernel Woes (http://www.nvnews.net/vbulletin/showthread.php?t=6526)

The Analog Kid 01-21-03 06:56 PM

Kernel Woes
 
I compiled 2.4.20 for learning purposes, everything goes well during boot up, except when I am in X and I login in, it gets to MagicDev or whatever its called and freezes. I used the configuration file that was used for compiling 2.4.18-9.8.0 or whatever it is.

jnd3 01-22-03 08:16 AM

Did you compile and install all the modules as well (make modules; make modules-install or something like that)? X is probably trying to load a module, can't find it, and gets lost in the weeds. If you're using an NV card, you'll have to reinstall the NV drivers under the new kernel as well. All kernel modules are stored in a kernel-specific directory.

Cheers,
JND

The Analog Kid 01-22-03 10:50 AM

Yes I compiled the modules. Since it is magic dev there must be a problem with either the floppy or the cdrom of which i have 2 a DVD and CD-RW, listed under /dev/cdrom /dev/cdrom1 respectively. I'll post a copy of my kernel config when i get home. I know that disabling MagicDev will solve the problem but I shouldn't have to.

The Analog Kid 01-22-03 05:59 PM

OK, I did a recompiling again with some modifications, now the system hangs on Red Hat Network.

Update: Ok I did another compiling because each time I find that I have stuff check yes that I don't need, and its back to MagicDev. Do I need to enable scsi support even if I don't have any scsi drives? Is that what is causing it.

The Analog Kid 01-23-03 04:17 PM

I now tried removing MagicDev like they say and now I only can get to yet again The Red Hat Nework_Icon.

jnd3 01-23-03 04:36 PM

Hmmm, the SCSI thing might be an issue. I know with mine it appends "hdc=ide-scsi" to the kernel boot parameters for my CDRW drive. I'd at least build the SCSI stuff as modules. That way it won't bloat up the kernel, but it'll load if it needs it. I think MagicDev is like the Windows auto-insert/auto-mount...but I'd have to check on that to be sure.

Cheers,
JND

The Analog Kid 01-24-03 04:17 PM

OK I enabled scsi, same result. I also enabled IPv6 if that could be the problem.


All times are GMT -5. The time now is 11:01 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.