nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   16:9 Displays 1280x768 1360x768 and rotation (http://www.nvnews.net/vbulletin/showthread.php?t=65737)

wahrheit2004 03-03-06 08:19 AM

16:9 Displays 1280x768 1360x768 and rotation
 
2 Attachment(s)
Hello,

seems that we have a lot of trouble running NVIDIA-Cards at "native" Resolutions of >32" TFT & Plasma screens.
Environment is SuSE 9.2 Pro and the NVIDIA 32bit Driver 1.0-8178
Different PCs, Geforce 5200FX && Geforce 6600GT tested.

PROBLEM #1
---> see .zip file
We set the resolution to 1360x768 Pixel, but Samsung MP 400P & LG L3200 show a Resolution of 1024x768 at their infopage in the OSD. To calculate the modeline we run:
Code:

xmode -r (Rate) -x 1360 -y 768
Rate is f.e. 60 fpr 60Hz

To check it we run
Code:

xdpyinfo | grep dimensions it shows "1360x768".
By inspecting the /var/log/XFree86.0.log there is the followin section:
Code:

(**) NVIDIA(0): Validated modes for display device CRT-0:
(**) NVIDIA(0):      Mode "1360x768": 81.8 MHz, 46.1 kHz, 58.0 Hz

So I think that everything shall be all right but OSD claims to get only "1024x768" :(.

PROBLEM #2
--> see ...rotate_problem.zip file
If we now add
Code:

Option "Rotate" "left"
we have a total systemcrash. nothing works anymore. only hard on/off helps, but even now it only boots to runlevel #3 (no X) and freezes again. Runlevel #1 & #2 work ...

netllama 03-03-06 10:37 AM

Re: 16:9 Displays 1280x768 1360x768 and rotation
 
For the 1360x768 issue, does it reproduce if you comment out the 1360x768 modeline? If so, please start X with the following command:
startx -- -logverbose 5
and then generate and post a new bug report.

Per the NVIDIA README, the RandR extention cannot be used with the "Rotate" option. Your X configuration is requesting both, however that shouldn't result in instability. Please verify whether using each one separately also triggers the crash.

Thanks,
Lonni

wahrheit2004 03-03-06 01:07 PM

Re: 16:9 Displays 1280x768 1360x768 and rotation
 
1 Attachment(s)
Hi Lonni,

thanks for paying attention to my issues.

PROBLEM 1
See new attached Log.

PROBLEM 2
Hmm... I can reproduce it every time here. What additional things can I do to give you more informations?

netllama 03-03-06 01:48 PM

Re: 16:9 Displays 1280x768 1360x768 and rotation
 
Your bug report does not have the 1360x768 modeline commented out as I requested. Did you test with the modeline commented out?

However, the bigger problem is that your display isn't even being detected:
(WW) NVIDIA(0): No boot display device found! Assuming one CRT
(WW) NVIDIA(0): Unable to read EDID for display device CRT-0

and as a result the EDID can't be read. Are you using a KVM, or any other intermediary device between the display and the videocard?

Both of your displays are flatpanel LCD TVs. Are you connecting them with an analog VGA cable?

You stated "I can reproduce it every time here.". I asked whether you can reproduce it with the RandR extention or the "Rotate" option, but not both together. Does this imply that either option triggers the instability?

Thanks,
Lonni


All times are GMT -5. The time now is 04:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.