nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Change to a higher resolution? (http://www.nvnews.net/vbulletin/showthread.php?t=6596)

msreddy 01-23-03 11:01 PM

Change to a higher resolution?
 
I have a NVIDIA GeForce4 Ti 4200 AGP 4X
Graphics Card, and a Gateway 18.1" LCD
Flat Panel Monitor. I am running Redhat Linux 7.3.

It gives me a max resolution of only 1024x768, where as in Windows XP, I
get a resolution up to 1280x1024.

Could any one please let me know how I can change the resolution to a higher one in Linux?

Initially, the XF86Config-4 file contained
only the following section:

Depth 16
Modes "1024x768" "800x600" "640x480'

and the DefaultDepth was set to 16.

I tried couple of things:

Changed the DefaultDepth to 24, and added:

Depth 24
Modes "1280x1024" "1280x960" "1024x960"

When it tires to start X, it just flcikers and after about three or four times, I get a message saying that X is trying to
refresh at a high rate (or something to that effect) and will be disabled for 5 minutes, and then I get back the
login promt (ofcourse, text mode).

I see the same thing, when I changed the Modes for Depth 16 to:
Modes "1280x1024" "1024x768" "800x600", with the default depth set to 16.

Do I have to load new versions of the driver from the nvidia web site?

I ran NVChooser.sh script, and it recommends me to load the following files:

NVIDIA_kernel-1.0-4191.rh73up.i686.rpm
and
NVIDIA_GLX-1.0-4191.i386.rpm

Thanks a lot.

Madhu Reddy

ReKleSS 01-25-03 12:12 AM

Check your hrefresh and vrefresh settings.
-ReK

msreddy 01-30-03 10:44 PM

Change to higher resolution - Solved.
 
Downloading the newer version of the NVIDIA drivers helped me solve this problem, i.e, I am now able to set the resolution to 1280x1024.

This is what I have done.

1.) Ran NVChooser.sh to determine what files
I needed to download, and it asked me to download
the following files:

NVIDIA_kernel-1.0-4191.rh73up.i686.rpm
NVIDIA_GLX-1.0-4191.i386.rpm

2.) Did "rpm -q NVIDIA_kernel" to determine
if there is an older version of the nvidia kernel
installed. And, there was none.

3.) Since this is a fresh install:
rpm -ivh NVIDIA_kernel-1.0-4191.rh73up.i686.rpm

and,
rpm -ivh NVIDIA_GLX-1.0-4191.i386.rpm

Both steps above completed fine without any problems.

4.) In XF86Config-4 file, commented out the
following:
#Load GLCore
#Load dri

And, ensured that the "Module" section has
Load glx

5.) In the Device section, changed:
Driver "vesa" to
Driver "nvidia"

6.) In the original XF86Config-4 file, I had a section like:

DefaultDepth 16

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

And I changed it to:

DefaultDepth 24

Subsection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1024x768"
EndSubsection

Subsection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1024x768"
EndSubsection

7.) Restarted X. Saw the NVIDIA logo, and then
the KDE login screen. I am now able to see the
1280x1024 resolution, which is the max resolution
that is supported by mo monitor/video card.


Prior to downloading these new drivers, no matter how I tweaked the XF86Config-4 file, I was not able to set resolution higher than 1024x768.

Thanks
Madhu

bwkaz 01-31-03 07:47 AM

That makes perfect sense if you weren't using nVidia's drivers before. Is that the case?

msreddy 01-31-03 03:05 PM

Yes, I was'nt using the NVIDIA drivers earlier.
I was using the regular "Vesa" drivers that came with Redhat 7.3

bwkaz 01-31-03 04:18 PM

Ah, yep. That makes sense. :)


All times are GMT -5. The time now is 03:52 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.