nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVDIA and console mode (http://www.nvnews.net/vbulletin/showthread.php?t=6611)

spurnelle 01-24-03 12:31 PM

NVDIA and console mode
 
I downloaded the latest kernel source, the compilation is correct and X mode work fine.
But when I switch to console, the text is unreadable.
beause the system don't switch to texte resolution.

Can anyone help me.

bwkaz 01-24-03 07:13 PM

Is your kernel using rivafb? Do a cat /proc/fb (AFAIK, this will work in X) to see the driver that's being used -- it should say "<some number> VESA VGA". If it says anything else, you very likely aren't using vesafb for the high-res text console (which isn't actually text mode, btw, it's a VESA standard mode with a BIOS font). vesafb is the only thing that will work with the nVidia X drivers.

spurnelle 01-25-03 07:14 AM

NVIDIA and console
 
I don't have a RIVA TNT, I have a GEFORCE 4 MX 420. I don't have some data in /proc/fb

bwkaz 01-25-03 09:17 AM

Right, but rivafb is the only driver under "framebuffer console" that has anything to do with nVidia, so a lot of people choose it as their console driver. Then they have problems with X.

If /proc/fb is empty, then are you even using a high-res console? Mine, for example, is 160x64 characters -- if yours is just 80x25, then it is indeed just normal text mode, and ignore what I've been saying. :o

Which distro is this, btw?

bimbo00 01-25-03 05:49 PM

same problem
 
I'm havin' the same problem described above.
My distro is Mandrake 9.0 (installed last night).
When I was using the vesa drivers for my X windows everything worked(well, not exactly :) I couldn't use the acceleration of my GeForce4 = couldn't play TUX )
I tried using my CRT monitor(usually I use an LCD) and it didn't work with it either.
oh and my proc/fb :
before restarting with the new drivers
0 VESA VGA
now, after restarting the PC the /proc/fb is just EMPTY :
-r--r--r-- 1 root root 0 Jan 25 17:46 fb

well that's it if you need more info just ask.

regards,
BimBo

spurnelle 01-26-03 05:42 AM

NVIDIA and console
 
My distro is RedHat 8.0 and console run with 80x25 text mode. Actually, I use the Xfree86 nvidia driver GEFORCE 4 generic (vesa) and when use CTRL-ALT-F1, the system change correctly the mode.

bimbo00 01-26-03 12:18 PM

well yeah
 
Well, my console worked when my computer was set exactly as yours :)
my console worked perfectly until installing the nVidia driver for the GeForce. Now with the driver it doesn't after starting X-Windows.
My computer boot in init 3 and the console works( it's not 80x25)
then after logging in and typing startx , X-Windows loads but the console is not accessable anymore. Exiting X-Windows doesn't fix the problem. I can still blindly type startx to get back to X-Windows.

bwkaz 01-26-03 01:41 PM

Does blindly doing a reset help at all? I've noticed that that will sometimes help after dumping an object file to the terminal, which screws up the character set in some cases, so that the prompt is made up of ASCII graphics characters rather than the normal "[user@host directory]$ " string. Running reset fixes this (well... the majority of the time anyway), so it is remotely possible that it might maybe help with your problem.

I don't know, it's just a guess.

I don't have any other ideas either, unfortunately...

Mirror176 01-26-03 02:13 PM

sounds like im in the same boat as u guys for the nost part. my unique variation is that i cannot see my console view at all becusse my nec multisync fe771sb monitor reports the frequency as out of range. as mentioned before by others, i can type startx to get back to a viewable screen if i exited it, or switch back to virtual terminal 7 where the xconsole resides if i didnt close it. rebooting also works. i havent tested much more because there isnt much ive wanted to do wothout seeing what im doing. im using slackware 8.1. i thought the previous version of the drivers worked ok so ill probably try going back to them when i get back to linux. in the meantime i have a bit of corruption in my partition table that needs correcting first.

Mirror176 01-26-03 02:14 PM

oh yea, my console is not a framebuffer, but rather the default fast and low res setting

bimbo00 01-26-03 02:57 PM

haha
well I have Samsung SyncMaster 171s(LCD) and that's exactly what it does :) And yeah I cannot see my console at all :)

Zippo 01-27-03 03:17 PM

Well... exactly the same problem. I have a Geforce4 MX440 and a Sony E200 monitor. Once I've started the X (which runs perfectly), I can't use the console (alt-F1, etc) anymore, although I can switch back to X graphic mode. It's impossible to use the virtual consoles because the screen is totaly blank. The monitor itself displays an error "out of scaning range". Should I change some configuration in XConfig or should I ask for support of nvidia people ?? Any suggestions ?
:confused:


All times are GMT -5. The time now is 08:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.