nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   Solaris 10 X86, 6600, DualHead: Login-Screen moved halfway across the 2 screens ... (http://www.nvnews.net/vbulletin/showthread.php?t=66268)

sunny_frankonia 03-13-06 12:33 PM

Solaris 10 X86, 6600, DualHead: Login-Screen moved halfway across the 2 screens ...
 
With my x86 and nvidia-drivers *8178, the 6600 with 2 vga CRTs connected,
sinlge screen is OK, nice high-res graphics thanks to driver "nvidia".

When going for dual-head as configured in the Xorg.conf with
Option "TwinView"
Intended Graphics-Res is 1024x768 for both monitors (they are a bit old, but huge ;)

The X starting sequence is

- from text mode boot switch to graphics
- NVIDIA splash-screen correctly displayed and stretched across both monitors
= white and NVIDIA-Logo in the center
- SUN login-screen comes up, but strangely centered in the middle of both monitors,
odd, since this login-screen is only "one screen wide", which leaves
half a black screen on the left half of the left monitor and
half a blalk screen on the right half of the right monitor
- after login, a fraction of a second later, the SUN login-screen re-appeares (= no X)

The X log file Xorg.0.log does not tell any errors.
(Apart from one unreal keyboard error, also shown, when not trying Option TwinView)

This applies to Solaris 10 3/5 running a user with CDE and with Java-Desktop
(no differences wrt. the TwinView not succeeding).

What did I miss? It seems to almost succeed, but missing a final detail.
Thanks for any suggestions.
Christian

netllama 03-13-06 12:45 PM

Re: Solaris 10 X86, 6600, DualHead: Login-Screen moved halfway across the 2 screens ...
 
It sounds like X might be crashing. Please generate and post a bug report, along with the '.old' X log.

Thanks,
Lonni

sunny_frankonia 03-13-06 02:27 PM

Re: Solaris 10 X86, 6600, DualHead: Login-Screen moved halfway across the 2 screens .
 
nvidia-bug-report.sh ... not found;
Where 2 get it? ... The original installer is only the run-file (appr. 10 MByte),
runs ok in non-X,
but does not install any additional files in its current running working directory.

The log-files from /var/log coming up with next posting.
Christian

netllama 03-13-06 02:53 PM

Re: Solaris 10 X86, 6600, DualHead: Login-Screen moved halfway across the 2 screens ...
 
For Solaris, please run nvidia-SunOS-bug-report.sh.

Thanks,
Lonni

sunny_frankonia 03-13-06 04:17 PM

Re: Solaris 10 X86, 6600, DualHead: Login-Screen moved halfway across the 2 screens .
 
Option "NoTwinViewXineramaInfo" "1" was missing !

Just found it in another thread of this solaris forum.
So: its not the Login-Screen sitting "between the two monitors" ... this is still the case !
Everything works nicely now, as expected.
(I hoped, that only one small bit was missing, since, when starting X,
the NVIDIA logo displayed OK streched across both screens, and
briefly, the old-fashioned X hourglass-mousepointer was there on an empty screen,
and it could be moved OK across both screens (if you are fast enough))
Just after that, X gave up and the Login-Screen re-appeared.

Anyway, also: Thank you NVIDIA Team at CeBIT computer fair 2006,
who told me to check this special forum for solaris only,
which is a great thing also.

Christian


All times are GMT -5. The time now is 08:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.