nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nForce2: "full screen" isn't (http://www.nvnews.net/vbulletin/showthread.php?t=6658)

richunger 01-25-03 08:43 PM

nForce2: "full screen" isn't
 
I'm running an nForce2 board with the IGP (and a single LCD display) and the binary drivers. When I run something full screen (mplayer, tuxracer, xawtv), I actually get a small area the size of the original window in the middle of an otherwise black screen.

Rich

bwkaz 01-26-03 08:35 AM

Are you sure you're loading the XFree86-VidModeExtension X extension? You can check with xdpyinfo -- the last few screens of lines are info on visuals, and just before that is the list of loaded extensions. If you don't see XFree86-VidModeExtension listed there, then you don't have it loaded.

I'm not quite sure how to load it, but I think it has something to do with the SubSection "extmod" in your Section "Modules" in your XF86Config(-4) file. But check to see if it's loaded before trying to get it to load, obviously. ;)

richunger 01-26-03 01:22 PM

I hadn't checked, but yes, it's in there:

number of extensions: 30
BIG-REQUESTS
DOUBLE-BUFFER
DPMS
Extended-Visual-Information
FontCache
GLX
LBX
MIT-SCREEN-SAVER
MIT-SHM
MIT-SUNDRY-NONSTANDARD
NV-CONTROL
NV-GLX
NVIDIA-GLX
RECORD
RENDER
SECURITY
SHAPE
SYNC
TOG-CUP
XC-APPGROUP
XC-MISC
XFree86-Bigfont
XFree86-DGA
XFree86-Misc
XFree86-VidModeExtension
XInputExtension
XKEYBOARD
XTEST
XVideo
XVideo-MotionCompensation

bwkaz 01-26-03 05:33 PM

Hmm... I'm not sure then.

Anyone else?

:-/

richunger 01-26-03 11:42 PM

Just discovered I can get full-screen with mplayer by forcing the output protocol to xv (-vo=xv). It had been defaulting to X11.

Tried the same thing with xawtv, but it didn't work.

richunger 01-28-03 02:29 AM

update, for those with the same problem: I figured out how to get xv output on xawtv. I had to load a "v4l" in the "Modules" section of my XF86Config-4. Evidently, this enables xvideo extensions for the v4l driver.

Oddly enough, when I run with xv enabled, and then I quit xawtv (or mplayer, or any other program viewing through my tv card), the audio from the tv card just keeps on going... very strange.

When i run xawtv -noxv, this doesn't happen (but of course I'm back to where I started, without fullscreen).


All times are GMT -5. The time now is 02:23 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.