nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Legacy Graphics Cards (http://www.nvnews.net/vbulletin/forumdisplay.php?f=37)
-   -   X server won't start (http://www.nvnews.net/vbulletin/showthread.php?t=67343)

lancherider 03-29-06 03:13 PM

X server won't start
 
I've installed the Nvidia drivers and they have compiled and installed with no problems. However, when I try to start the X server, it fails. Here is relevant info from Xorg.0.log:

Code:

(II) NVIDIA X Driver  1.0-8178  Wed Dec 14 16:25:22 PST 2005
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(WW) The NVIDIA GeForce2 Ultra GPU installed in this system is
(WW)      supported through the NVIDIA Legacy drivers. Please visit
(WW)      http://www.nvidia.com/object/unix.html for more
(WW)      information.  The 1.0-8178 NVIDIA driver will ignore this
(WW)      GPU.  Continuing probe...
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
        at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

This is a Fedora Core 4 machine. Is there a different driver I need to load? If so, which one? How far back should I go? Many thanks.

Son Goku 03-29-06 10:10 PM

Re: X server won't start
 
Might help if you tell people what your card is. Is it a GF 2 GTS?

Also, have you tried an xconfigurator (if that's what the thing is in Fedora) and selected your gfx card? If it's a GF2 GTS, there probably is a bundled driver for the GF in the OS already...

Perhaps someone can suggest something more, if you want to get the driver off nVidia's site going, and there's a configuration change you might try...

lancherider 03-30-06 10:54 AM

Re: X server won't start
 
The card is a GeForce2 Ultra. There are drivers that are bundled with the OS, but I'm getting horizontal streaking with those, and in my experience with other machines, the nVidia specific drivers are more effective.

jaykup 05-12-06 07:21 PM

Re: X server won't start
 
When you go to the Nvidia archives, you need to select the drivers under "supported list", like 6629 i believe.

logistiker 06-09-06 11:10 AM

Re: X server won't start
 
The latest legacy driver is version 7174. I have an original Geforce 256 and I don't have any problems with it. Also depending on your kernel version, you might have to patch the driver so it compiles properly. If you were using Gentoo, they would already apply the necessary patches for you but in this case, you should be able to get the patches off this forum. I have gotten the 7174 driver to compile on x86 using kernel 2.6.16 but it as yet still doesn't have a patch to compile on AMD64 using 2.6.16 although the 7174 driver does work on kernel 2.6.15 on AMD64.


All times are GMT -5. The time now is 04:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.